ramips: add support for Ubiquiti EdgeRouter X (UBNT-ERX)
[openwrt.git] / target / linux / ramips / mt7621 / profiles / ubnt.mk
diff --git a/target/linux/ramips/mt7621/profiles/ubnt.mk b/target/linux/ramips/mt7621/profiles/ubnt.mk
new file mode 100644 (file)
index 0000000..b66b206
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/UBNT-ERX
+       NAME:=Ubiquiti EdgeRouter X
+       FEATURES+=nand -usb
+       PACKAGES:=-kmod-mt76 -wpad-mini -kmod-cfg80211
+endef
+
+define Profile/UBNT-ERX/Description
+       Package set compatible with the Ubiquiti EdgeRouter X
+endef
+$(eval $(call Profile,UBNT-ERX))