ramips: add additional support for MQmaker WiTi board
[openwrt.git] / target / linux / ramips / mt7621 / profiles / mqmaker.mk
diff --git a/target/linux/ramips/mt7621/profiles/mqmaker.mk b/target/linux/ramips/mt7621/profiles/mqmaker.mk
new file mode 100644 (file)
index 0000000..ae35e7d
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/witi
+       NAME:=MQmaker WiTi
+       FEATURES+=rtc
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 kmod-usb-hid kmod-sdhci-mt7620 \
+               kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+               kmod-rtc-pcf8563 kmod-i2c-mt7621
+endef
+
+define Profile/witi/Description
+       Package set compatible with MQmaker WiTi board.
+endef
+$(eval $(call Profile,witi))