ralink: drop dwc_otg support. dwc2 seems stable
[openwrt.git] / target / linux / ramips / modules.mk
index cff4d71..5b57f4c 100644 (file)
@@ -5,26 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define KernelPackage/usb-rt305x-dwc_otg
-  TITLE:=RT305X USB controller driver
-  DEPENDS:=@TARGET_ramips_rt305x
-  KCONFIG:= \
-       CONFIG_DWC_OTG \
-       CONFIG_DWC_OTG_HOST_ONLY=y \
-       CONFIG_DWC_OTG_DEVICE_ONLY=n \
-       CONFIG_DWC_OTG_DEBUG=n
-  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
-  AUTOLOAD:=$(call AutoLoad,54,dwc_otg,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-rt305x-dwc_otg/description
- This driver provides USB Device Controller support for the
- Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-rt305x-dwc_otg))
-
 OTHER_MENU:=Other modules
 define KernelPackage/sdhci-mt7620
   SUBMENU:=Other modules