brcm2708: add support for multi-device images
[openwrt.git] / target / linux / brcm2708 / image / Makefile
index 22c1218..53e5f54 100644 (file)
@@ -12,9 +12,9 @@ FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 ### Image scripts ###
-define Build/gen-cfg
-       cat config.txt > $@.config
-       echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
+define Build/kernel-img
+       perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
+       mv $@.tmp $@
 endef
 
 define Build/boot-img
@@ -28,9 +28,9 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/fixup.dat ::
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
-       mcopy -i $@.boot $@.config ::config.txt
+       mcopy -i $@.boot config.txt ::
        mcopy -i $@.boot $(word 1,$^) ::kernel.img
-       mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
+       $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::)
        mmd -i $@.boot ::/overlays
        mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
        mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
@@ -46,9 +46,9 @@ endef
 define Device/Default
   FILESYSTEMS := ext4
   PROFILES = Default $$(DEVICE_PROFILE)
-  KERNEL := kernel-bin
+  KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
-  IMAGE/sdcard.img := gen-cfg | boot-img | sdcard-img
+  IMAGE/sdcard.img := boot-img | sdcard-img
   DEVICE_PROFILE :=
   DEVICE_DTS :=
 endef
@@ -67,18 +67,14 @@ endef
 
 ### BCM2708/BCM2835 ###
 ifeq ($(SUBTARGET),bcm2708)
-  # Raspberry Pi Model B
-  $(eval $(call bcm270x,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
-  # Raspberry Pi Model B+
-  $(eval $(call bcm270x,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
-  # Raspberry Pi Compute Module
-  $(eval $(call bcm270x,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
+  # Raspberry Pi Models B/B+/CM
+  $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
 endif
 
 ### BCM2709/BCM2836 ###
 ifeq ($(SUBTARGET),bcm2709)
   # Raspberry Pi 2 Model B
-  $(eval $(call bcm270x,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+  $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
 endif
 
 $(eval $(call BuildImage))