openssl: 1.0.2b (hey, we made it nearly 3 months this time!)
[openwrt.git] / package / libs / openssl / patches / 200-parallel_build.patch
index c2eeb38..ff63e02 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile.org
 +++ b/Makefile.org
-@@ -274,17 +274,17 @@ build_all: build_libs build_apps build_t
- build_libs: build_crypto build_ssl build_engines
+@@ -277,17 +277,17 @@ build_libcrypto: build_crypto build_engi
+ build_libssl: build_ssl libssl.pc
  
  build_crypto:
 -      @dir=crypto; target=all; $(BUILD_ONE_CMD)
@@ -29,8 +29,8 @@
  
  all_testapps: build_libs build_testapps
  build_testapps:
-@@ -453,7 +453,7 @@ report:
-       @$(PERL) util/selftest.pl
+@@ -459,7 +459,7 @@ update: errors stacks util/libeay.num ut
+       @set -e; target=update; $(RECURSIVE_BUILD_CMD)
  
  depend:
 -      @set -e; target=depend; $(RECURSIVE_BUILD_CMD)
@@ -38,7 +38,7 @@
  
  lint:
        @set -e; target=lint; $(RECURSIVE_BUILD_CMD)
-@@ -531,9 +531,9 @@ dist:
+@@ -521,9 +521,9 @@ dist:
  dist_pem_h:
        (cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
  
@@ -50,7 +50,7 @@
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
                $(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -542,12 +542,19 @@ install_sw:
+@@ -532,12 +532,19 @@ install_sw:
                $(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
                $(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -71,7 +71,7 @@
        @set -e; liblist="$(LIBS)"; for i in $$liblist ;\
        do \
                if [ -f "$$i" ]; then \
-@@ -631,12 +638,7 @@ install_html_docs:
+@@ -621,12 +628,7 @@ install_html_docs:
                done; \
        done
  
  
  apps:
        @(cd ..; $(MAKE) DIRS=apps all)
-@@ -529,7 +529,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
+@@ -530,7 +530,7 @@ $(CONSTTIMETEST)$(EXE_EXT): $(CONSTTIMET
  #     fi
  
  dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)