find attached the announced patch for fuse.
[openwrt.git] / package / fuse / Makefile
index 152c540..17c5269 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,22 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.7.4
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.3
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=4879f06570d2225667534c37fea04213
+PKG_MD5SUM:=517c8384f915e40647bda9f71579fd97
+
+PKG_INSTALL:=1
+
+# Kernel 2.4 Module
+FUSE24_VERSION=2.5.3
+FUSE24_SOURCE:=$(PKG_NAME)-$(FUSE24_VERSION).tar.gz
+FUSE24_MD5SUM:=9c7e8b6606b9f158ae20b8521ba2867c
+FUSE24_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(FUSE24_VERSION)
+FUSE24_INSTALL_DIR:=$(FUSE24_BUILD_DIR)/ipkg-install
+FUSE24_PATCH_DIR:=./patches-kernel24
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -38,18 +48,24 @@ endef
 
 define Package/fuse-utils/description
 $(call Package/fuse/Default/description)
- This package contains the FUSE utility 'fusermount'.
+ This package contains the FUSE utilities.
+ - fusermount
+ - ulockmgr_server
 endef
 
 define KernelPackage/fuse
-$(call Package/fuse/Default)
-  SUBMENU:=Filesystems
-  DEPENDS:=@LINUX_2_6
-  TITLE+= (kernel module)
-  KCONFIG:= CONFIG_FUSE_FS
-  FILES:=$(LINUX_DIR)/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,80,fuse)
-  VERSION:=$(LINUX_VERSION)
+       $(call Package/fuse/Default)
+       SUBMENU:=Filesystems
+       TITLE+= (kernel module)
+       ifeq ($(KERNEL),2.4)
+               FILES:=$(FUSE24_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
+               VERSION:=$(LINUX_VERSION)+$(FUSE24_VERSION)-$(PKG_RELEASE)
+       else
+               KCONFIG:= CONFIG_FUSE_FS
+               FILES:=$(LINUX_DIR)/fs/fuse/fuse.$(LINUX_KMOD_SUFFIX)
+               VERSION:=$(LINUX_VERSION)-$(LINUX_RELEASE)
+       endif
+       AUTOLOAD:=$(call AutoLoad,80,fuse)
 endef
 
 define KernelPackage/fuse/description
@@ -62,76 +78,144 @@ $(call Package/fuse/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= (library)
-  DEPENDS:=+LINUX_2_4:kmod-fuse24 +LINUX_2_6:kmod-fuse
+  DEPENDS:=kmod-fuse
   SUBMENU:=Filesystem
 endef
 
 define Package/libfuse/description
 $(call Package/fuse/Default/description)
- This package contains the FUSE shared library, needed by other programs.
+ This package contains the FUSE shared libraries, needed by other programs.
+ - libfuse
+ - libulockmgr
 endef
 
-CONFIGURE_VARS += \
-        kernsrcver="$(LINUX_VERSION)"
-
+# generic args
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-rpath \
-       --enable-lib \
-       --enable-util \
        --disable-example \
-       --disable-auto-modprobe \
-       --with-kernel="$(LINUX_DIR)" \
        --disable-mtab 
 
-# Since kernel 2.6.14 the fuse module is officially part of the kernel. 
-# Generally it is better to use the kernel's module. Because it is patched
-# against the DCACHE BUG on arm architectures (currently brcm-2.4, brcm-47xx) 
-# and from fuse 2.8.0 on it will be removed from the fuse package anyway.
-#
-CONFIGURE_ARGS += --disable-kernel-module
+# kmod 2.4 args
+FUSE24_CONFIGURE_ARGS := $(CONFIGURE_ARGS) \
+       --disable-lib --disable-util \
+       --enable-kernel-module --disable-auto-modprobe \
+       --with-kernel="$(LINUX_DIR)"
+
+# generic package uses lib & utils
+CONFIGURE_ARGS += --enable-lib --enable-util
+
+####### FUSE24 - START ######
+### if we're on kernel 2.4 build a kernel 2.4 compatible fuse module from older version, see also
+### http://sourceforge.net/apps/mediawiki/fuse/index.php?title=FAQ#What_version_of_FUSE_do_I_need_to_use_FUSE_with_Linux_2.4.3F
+ifeq ($(KERNEL),2.4)
+
+define Download/fuse24
+       FILE:=$(FUSE24_SOURCE)
+       URL:=$(PKG_SOURCE_URL)
+       MD5SUM:=$(FUSE24_MD5SUM)
+endef
+$(eval $(call Download,fuse24))
+
+define Build/Prepare/fuse24
+       rm -rf $(FUSE24_BUILD_DIR)/
+       mkdir -p $(FUSE24_BUILD_DIR)/
+       $(TAR) -xzf $(DL_DIR)/$(FUSE24_SOURCE) -C $(FUSE24_BUILD_DIR)/..
+endef
+
+define Build/Patch/fuse24
+       $(call PatchDir,$(FUSE24_BUILD_DIR),$(FUSE24_PATCH_DIR),)
+endef
+
+define Build/Configure/fuse24
+       (cd $(FUSE24_BUILD_DIR); \
+               rm -rf config.{cache,status} ; \
+               $(CONFIGURE_VARS) \
+               ./configure \
+                       $(FUSE24_CONFIGURE_ARGS) \
+       );
+endef
+
+define Build/Compile/fuse24
+       $(MAKE) -C $(FUSE24_BUILD_DIR)/$(MAKE_PATH) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               all;
+endef
+
+define Build/Install/fuse24
+       rm -rf $(FUSE24_INSTALL_DIR)
+       mkdir -p $(FUSE24_INSTALL_DIR)
+       $(MAKE) -C $(FUSE24_BUILD_DIR) \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               DESTDIR="$(FUSE24_INSTALL_DIR)" \
+               install
+endef
+
+define Build/Prepare
+       @echo "--> Build/Prepare enter"
+       $(call Build/Prepare/fuse24)
+       $(call Build/Patch/fuse24)
+       $(call Build/Prepare/Default)
+       @echo "--> Build/Prepare leave"
+endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.in ; \
-               touch aclocal.m4 ; \
-               touch Makefile.in ; \
-               touch include/config.h.in ; \
-               touch configure ; \
-       )
+       @echo "--> Build/Configure enter"
+       $(call Build/Configure/fuse24)
        $(call Build/Configure/Default)
+       @echo "--> Build/Configure leave"
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               AM_CFLAGS="$(TARGET_CFLAGS) -DDISABLE_COMPAT=1" \
-               EXTRA_DIST="" \
-               all install
+       @echo "--> Build/Compile enter"
+       $(call Build/Compile/fuse24)
+       $(call Build/Compile/Default)
+       @echo "--> Build/Compile leave"
+endef
+
+define Build/Install
+       @echo "--> Build/Install enter"
+       $(call Build/Install/fuse24)
+       $(call Build/Install/Default)
+       @echo "--> Build/Install leave"
 endef
 
+endif
+####### FUSE24 - END ######
+
 define Build/InstallDev
+       @echo "--> Build/InstallDev enter"
        mkdir -p $(1)/usr/include
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/fuse{,.h} $(1)/usr/include/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/include/{fuse,*.h} $(1)/usr/include/
        mkdir -p $(1)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/libfuse.{a,so*} $(1)/usr/lib/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/*.{a,so*} $(1)/usr/lib/
        mkdir -p $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/fuse.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-I$$$${includedir}/fuse,,g' $(1)/usr/lib/pkgconfig/fuse.pc
        $(SED) 's,-L$$$${libdir},,g' $(1)/usr/lib/pkgconfig/fuse.pc
+       @echo "--> Build/InstallDev leave"
 endef
 
 define Package/fuse-utils/install
+       @echo "--> Package/fuse-utils/install enter"
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fusermount $(1)/usr/bin/
+       # use cp and keep fusermount sticky bit
+       $(FIND) $(PKG_INSTALL_DIR)/usr/bin/ -type f -exec $(CP) -a {} $(1)/usr/bin/ \;
+       @echo "--> Package/fuse-utils/install leave"
 endef
 
 define Package/libfuse/install
+       @echo "--> Package/libfuse/install enter"
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfuse.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+       @echo "--> Package/libfuse/install leave"
+endef
+
+define Package/kmod-fuse/install
+       @echo "--> Package/kmod-fuse/install enter/leave"
 endef
 
 $(eval $(call BuildPackage,fuse-utils))