[package] block-mount: Merged block-mount, block-extroot, and block-hotplug into...
[openwrt.git] / package / block-mount / Makefile
index 267a200..05ca086 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=block-mount
-PKG_VERSION:=0.1.0
-PKG_RELEASE:=3
+PKG_VERSION:=0.2.0
+PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,20 +22,20 @@ define Package/block-mount
   $(call Package/block-mount/Default)
   TITLE:=Block device mounting and checking
   DEPENDS:= +blkid +swap-utils 
+  MENU:=1
 endef
 
 define Package/block-mount/description
-  Scripts used to mount and check block devices (filesystems and swap)
+  Scripts used to mount and check block devices (filesystems and swap), as well
+  as hotplug scripts to automount and check block devices when hotplug event (e.g.
+  from plugging in a device) occurs.
+  Also includes preinit scripts for mounting a block device as the root filesystem.
+  This allows one to have the root filesystem on devices other than the built in flash
+  device.
 endef
 
-define Package/block-hotplug
-  $(call Package/block-mount/Default)
-  TITLE:=Automount and autocheck block devices
-  DEPENDS:=+block-mount +hotplug2
-endef
-
-define Package/block-hotplug/description
-  Scripts used to automatically check and mount filesystem and/or swap
+define Package/block-mount/config
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Compile
@@ -54,15 +54,19 @@ define Package/block-mount/install
        $(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
        $(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
        $(INSTALL_DATA) ./files/block.sh $(1)/lib/functions/
-endef
-
-define Package/block-hotplug/install
        $(INSTALL_DIR) $(1)/etc/hotplug.d/block
        $(INSTALL_DATA) ./files/10-swap $(1)/etc/hotplug.d/block/
        $(INSTALL_DATA) ./files/20-fsck $(1)/etc/hotplug.d/block/
        $(INSTALL_DATA) ./files/40-mount $(1)/etc/hotplug.d/block/
+       $(INSTALL_DIR) $(1)/lib/functions
+       $(INSTALL_DATA) ./files/extmount.sh $(1)/lib/functions/
+       $(INSTALL_DIR) $(1)/lib/preinit
+       $(INSTALL_DATA) ./files/50_determine_usb_root $(1)/lib/preinit/
+       $(INSTALL_DATA) ./files/55_determine_extroot_sysupgrade $(1)/lib/preinit/
+       $(INSTALL_DATA) ./files/60_pivot_usb_root $(1)/lib/preinit/
+       $(INSTALL_DIR) $(1)/lib/preinit
+       echo "extroot_settle_time=\"$(CONFIG_EXTROOT_SETTLETIME)\"" >$(1)/lib/preinit/00_extroot.conf
+       $(INSTALL_DIR) $(1)/overlay
 endef
 
 $(eval $(call BuildPackage,block-mount))
-$(eval $(call BuildPackage,block-hotplug))
-