improve xargs compatibility check (mostly Darwin/Mac OS X related)
[openwrt.git] / include / host.mk
index 00eb1f5..9d40ec4 100644 (file)
@@ -39,12 +39,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                else \
                        echo 'FIND_L=find $$(1) -follow' >> $@; \
                fi; \
+               if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
+                       echo 'XARGS:=xargs -r' >> $@; \
+               else \
+                       echo 'XARGS:=xargs' >> $@; \
+               fi; \
        )
 
 endif
-
-ifeq ($(HOST_OS),Linux)
-  XARGS:=xargs -r
-else
-  XARGS:=xargs
-endif