include/cmake.mk: Add helper macro to handle conditionals for CMake boolean type...
[openwrt.git] / include / cmake.mk
index a15cf3a..009c6c2 100644 (file)
@@ -1,3 +1,5 @@
+cmake_bool = $(patsubst %,-D%:BOOL=$(if $($(1)),ON,OFF),$(2))
+
 PKG_INSTALL:=1
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)