add a "make prepare" target which builds everything up to target/compile, useful...
[openwrt.git] / Makefile
index 6cf4a4b..db79274 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,6 +48,8 @@ $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
        @touch $@
 
+prepare: $(target/stamp-compile)
+
 clean: FORCE
        $(_SINGLE)$(SUBMAKE) target/linux/clean
        rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)