ar71xx: Backport support for Onion Omega
[15.05/openwrt.git] / target / linux / ar71xx / generic / profiles / onion.mk
diff --git a/target/linux/ar71xx/generic/profiles/onion.mk b/target/linux/ar71xx/generic/profiles/onion.mk
new file mode 100644 (file)
index 0000000..dd5874e
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OMEGA
+   NAME:=Onion Omega
+   PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-storage kmod-i2c-core kmod-i2c-gpio-custom kmod-spi-bitbang kmod-spi-dev kmod-spi-gpio kmod-spi-gpio-custom kmod-usb-serial
+endef
+
+define Profile/OMEGA/Description
+   Package set optimized for the Onion Omega development platform.
+endef
+$(eval $(call Profile,OMEGA))