hostapd: fix build error on some variants with CONFIG_WPA_RFKILL_SUPPORT=y (#17765)
[15.05/openwrt.git] / package / network / services / hostapd / Makefile
index 838ef39..19d536e 100644 (file)
@@ -71,7 +71,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_IEEE80211N=$(HOSTAPD_IEEE80211N) \
        CONFIG_IEEE80211W=$(CONFIG_PACKAGE_kmod-ath9k) \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
-       $(if $(CONFIG_WPA_RFKILL_SUPPORT),NEED_RFKILL=y)
 
 ifneq ($(LOCAL_TYPE),hostapd)
   ifdef CONFIG_WPA_SUPPLICANT_OPENSSL
@@ -83,6 +82,9 @@ ifneq ($(LOCAL_TYPE),hostapd)
   ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
     TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
   endif
+  ifdef CONFIG_WPA_RFKILL_SUPPORT)
+    DRIVER_MAKEOPTS += NEED_RFKILL=y
+  endif
   DRIVER_MAKEOPTS += \
        CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif