move hardware monitoring support in a separate hwmon.mk (before adding other modules)
[openwrt.git] / package / kernel / modules / other.mk
index 0e3368b..7bb75ef 100644 (file)
@@ -332,43 +332,6 @@ endef
 $(eval $(call KernelPackage,scx200-wdt))
 
 
-define KernelPackage/hwmon
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Hardware monitoring support
-  DEPENDS:=@LINUX_2_6
-  KCONFIG:= \
-       CONFIG_HWMON \
-       CONFIG_HWMON_VID \
-       CONFIG_HWMON_DEBUG_CHIP=n
-  FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX) \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
-endef
-
-define KernelPackage/hwmon/description
- Kernel modules for hardware monitoring
-endef
-
-$(eval $(call KernelPackage,hwmon))
-
-
-define KernelPackage/hwmon-pc87360
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=PC87360 monitoring support
-  DEPENDS:=kmod-hwmon
-  KCONFIG:=CONFIG_SENSORS_PC87360
-  FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,pc87360)
-endef
-
-define KernelPackage/hwmon-pc87360/description
- Kernel modules for PC87360 chips
-endef
-
-$(eval $(call KernelPackage,hwmon-pc87360))
-
-
 define KernelPackage/input-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Input device core