add strict mode flag (enabled by default, can be disabled to ignore lines with parser...
[project/uci.git] / Makefile
index ecfa8bc..c136915 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,7 @@
 COPTS=-O2
 CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
 ifneq ($(DEBUG),)
+  COPTS = -O0
   CFLAGS += -g3 -DDEBUG_ALL
 endif