fix double free bug
[project/uci.git] / Makefile
index bf194d1..01063a8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,12 +1,21 @@
+COPTS=-g -O2
+CFLAGS=$(COPTS) -fPIC -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+
+AR=ar
 CC=gcc
-CFLAGS=-O2 -Wall -pedantic -std=gnu99 -Wno-unused -Werror
+RANLIB=ranlib
+
+all: uci
 
-all: parsetest
-parsetest: libuci.o test.o
+cli.o: cli.c uci.h
+uci: cli.o libuci.a
        $(CC) $(CFLAGS) -o $@ $^
 
-libuci.o: libuci.c parse.c libuci.h list.c err.h
-test.o: test.c libuci.h
+libuci.o: libuci.c file.c uci.h list.c err.h
+libuci.a: libuci.o
+       rm -f $@
+       $(AR) rc $@ $^
+       $(RANLIB) $@
 
 clean:
-       rm -f parsetest *.o
+       rm -f uci *.[oa]