fix libnl detection
authorThomas Gstädtner <thomas@gstaedtner.net>
Sun, 3 Mar 2013 17:20:10 +0000 (18:20 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Mar 2013 17:41:49 +0000 (18:41 +0100)
CMakeLists.txt

index 2076fc9..f7e9a04 100644 (file)
@@ -23,7 +23,8 @@ SET(LIBS
        ubox ubus uci ${json} blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
        ubox ubus uci ${json} blobmsg_json)
 
 IF (NOT DEFINED LIBNL_LIBS)
-  SET(LIBNL_LIBS -lnl)
+  FIND_LIBRARY(libnl NAMES libnl-3 libnl nl-3 nl)
+  SET(LIBNL_LIBS ${libnl})
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
 ENDIF()
 
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)