split alias support into a separate source file for better readability
authorFelix Fietkau <nbd@openwrt.org>
Thu, 5 Jul 2012 17:58:46 +0000 (19:58 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 5 Jul 2012 17:58:57 +0000 (19:58 +0200)
CMakeLists.txt
alias.c [new file with mode: 0644]
device.c
device.h

index 7a97aa6..4ef4dfa 100644 (file)
@@ -14,7 +14,9 @@ SET(SOURCES
        main.c utils.c system.c tunnel.c
        interface.c interface-ip.c interface-event.c
        proto.c proto-static.c proto-shell.c
-       config.c device.c bridge.c vlan.c ubus.c)
+       config.c device.c bridge.c vlan.c alias.c
+       ubus.c)
+
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
diff --git a/alias.c b/alias.c
new file mode 100644 (file)
index 0000000..338ece6
--- /dev/null
+++ b/alias.c
@@ -0,0 +1,131 @@
+/*
+ * netifd - network interface daemon
+ * Copyright (C) 2012 Felix Fietkau <nbd@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ */
+#include <string.h>
+#include <stdlib.h>
+#include <stdio.h>
+
+#include "netifd.h"
+#include "device.h"
+
+static struct avl_tree aliases;
+
+struct alias_device {
+       struct avl_node avl;
+       struct device dev;
+       struct device_user dep;
+       bool cleanup;
+       char name[];
+};
+
+static const struct device_type alias_device_type;
+
+static int
+alias_device_set_state(struct device *dev, bool state)
+{
+       struct alias_device *alias;
+
+       alias = container_of(dev, struct alias_device, dev);
+       if (!alias->dep.dev)
+               return -1;
+
+       if (state)
+               return device_claim(&alias->dep);
+
+       device_release(&alias->dep);
+       if (alias->cleanup)
+               device_remove_user(&alias->dep);
+       return 0;
+}
+
+static struct device *
+alias_device_create(const char *name, struct blob_attr *attr)
+{
+       struct alias_device *alias;
+
+       alias = calloc(1, sizeof(*alias) + strlen(name) + 1);
+       strcpy(alias->name, name);
+       alias->dev.set_state = alias_device_set_state;
+       alias->dev.hidden = true;
+       device_init_virtual(&alias->dev, &alias_device_type, NULL);
+       alias->avl.key = alias->name;
+       avl_insert(&aliases, &alias->avl);
+
+       return &alias->dev;
+}
+
+static void alias_device_free(struct device *dev)
+{
+       struct alias_device *alias;
+
+       alias = container_of(dev, struct alias_device, dev);
+       avl_delete(&aliases, &alias->avl);
+       free(alias);
+}
+
+static const struct device_type alias_device_type = {
+       .name = "Network alias",
+       .create = alias_device_create,
+       .free = alias_device_free,
+};
+
+void
+alias_notify_device(const char *name, struct device *dev)
+{
+       struct alias_device *alias;
+
+       device_lock();
+
+       alias = avl_find_element(&aliases, name, alias, avl);
+       if (!alias)
+               return;
+
+       alias->cleanup = !dev;
+       if (dev) {
+               if (dev != alias->dep.dev) {
+                       device_remove_user(&alias->dep);
+                       strcpy(alias->dev.ifname, dev->ifname);
+                       device_add_user(&alias->dep, dev);
+                       alias->dev.hidden = false;
+                       device_broadcast_event(&alias->dev, DEV_EVENT_UPDATE_IFNAME);
+               }
+       }
+
+       device_set_present(&alias->dev, !!dev);
+
+       if (!dev && alias->dep.dev && !alias->dep.dev->active) {
+               device_remove_user(&alias->dep);
+               alias->dev.hidden = true;
+               alias->dev.ifname[0] = 0;
+               device_broadcast_event(&alias->dev, DEV_EVENT_UPDATE_IFNAME);
+       }
+
+       device_unlock();
+}
+
+struct device *
+device_alias_get(const char *name)
+{
+       struct alias_device *alias;
+
+       alias = avl_find_element(&aliases, name, alias, avl);
+       if (alias)
+               return &alias->dev;
+
+       return alias_device_create(name, NULL);
+}
+
+static void __init alias_init(void)
+{
+       avl_init(&aliases, avl_strcmp, false, NULL);
+}
index cc41b20..34ad9ad 100644 (file)
--- a/device.c
+++ b/device.c
 #include "config.h"
 
 static struct avl_tree devices;
-static struct avl_tree aliases;
-
-struct alias_device {
-       struct avl_node avl;
-       struct device dev;
-       struct device_user dep;
-       bool cleanup;
-       char name[];
-};
-
-static const struct device_type alias_device_type;
 
 static const struct blobmsg_policy dev_attrs[__DEV_ATTR_MAX] = {
        [DEV_ATTR_TYPE] = { "type", BLOBMSG_TYPE_STRING },
@@ -137,55 +126,6 @@ const struct device_type simple_device_type = {
        .free = simple_device_free,
 };
 
-static int
-alias_device_set_state(struct device *dev, bool state)
-{
-       struct alias_device *alias;
-
-       alias = container_of(dev, struct alias_device, dev);
-       if (!alias->dep.dev)
-               return -1;
-
-       if (state)
-               return device_claim(&alias->dep);
-
-       device_release(&alias->dep);
-       if (alias->cleanup)
-               device_remove_user(&alias->dep);
-       return 0;
-}
-
-static struct device *
-alias_device_create(const char *name, struct blob_attr *attr)
-{
-       struct alias_device *alias;
-
-       alias = calloc(1, sizeof(*alias) + strlen(name) + 1);
-       strcpy(alias->name, name);
-       alias->dev.set_state = alias_device_set_state;
-       alias->dev.hidden = true;
-       device_init_virtual(&alias->dev, &alias_device_type, NULL);
-       alias->avl.key = alias->name;
-       avl_insert(&aliases, &alias->avl);
-
-       return &alias->dev;
-}
-
-static void alias_device_free(struct device *dev)
-{
-       struct alias_device *alias;
-
-       alias = container_of(dev, struct alias_device, dev);
-       avl_delete(&aliases, &alias->avl);
-       free(alias);
-}
-
-static const struct device_type alias_device_type = {
-       .name = "Network alias",
-       .create = alias_device_create,
-       .free = alias_device_free,
-};
-
 static void
 device_merge_settings(struct device *dev, struct device_settings *n)
 {
@@ -238,7 +178,6 @@ device_init_settings(struct device *dev, struct blob_attr **tb)
 static void __init dev_init(void)
 {
        avl_init(&devices, avl_strcmp, true, NULL);
-       avl_init(&aliases, avl_strcmp, false, NULL);
 }
 
 void device_broadcast_event(struct device *dev, enum device_event ev)
@@ -253,40 +192,6 @@ void device_broadcast_event(struct device *dev, enum device_event ev)
        }
 }
 
-void
-alias_notify_device(const char *name, struct device *dev)
-{
-       struct alias_device *alias;
-
-       device_lock();
-
-       alias = avl_find_element(&aliases, name, alias, avl);
-       if (!alias)
-               return;
-
-       alias->cleanup = !dev;
-       if (dev) {
-               if (dev != alias->dep.dev) {
-                       device_remove_user(&alias->dep);
-                       strcpy(alias->dev.ifname, dev->ifname);
-                       device_add_user(&alias->dep, dev);
-                       alias->dev.hidden = false;
-                       device_broadcast_event(&alias->dev, DEV_EVENT_UPDATE_IFNAME);
-               }
-       }
-
-       device_set_present(&alias->dev, !!dev);
-
-       if (!dev && alias->dep.dev && !alias->dep.dev->active) {
-               device_remove_user(&alias->dep);
-               alias->dev.hidden = true;
-               alias->dev.ifname[0] = 0;
-               device_broadcast_event(&alias->dev, DEV_EVENT_UPDATE_IFNAME);
-       }
-
-       device_unlock();
-}
-
 int device_claim(struct device_user *dep)
 {
        struct device *dev = dep->dev;
@@ -393,18 +298,6 @@ device_create_default(const char *name, bool external)
        return dev;
 }
 
-static struct device *
-device_alias_get(const char *name)
-{
-       struct alias_device *alias;
-
-       alias = avl_find_element(&aliases, name, alias, avl);
-       if (alias)
-               return &alias->dev;
-
-       return alias_device_create(name, NULL);
-}
-
 struct device *
 device_get(const char *name, int create)
 {
index 108d383..88a421f 100644 (file)
--- a/device.h
+++ b/device.h
@@ -181,6 +181,7 @@ void device_free_unused(struct device *dev);
 
 struct device *get_vlan_device_chain(const char *ifname, bool create);
 void alias_notify_device(const char *name, struct device *dev);
+struct device *device_alias_get(const char *name);
 
 static inline void
 device_set_deferred(struct device *dev, bool value)