add an install target
[project/netifd.git] / CMakeLists.txt
index 47a3509..8982a0d 100644 (file)
@@ -12,16 +12,20 @@ ENDIF()
 
 SET(SOURCES
        main.c utils.c
-       interface.c interface-ip.c interface-hotplug.c
+       interface.c interface-ip.c interface-event.c
        proto.c proto-static.c proto-shell.c
        config.c device.c bridge.c vlan.c ubus.c)
 
 SET(LIBS
        ubox ubus uci json blobmsg_json)
 
+IF (NOT DEFINED LIBNL_LIBS)
+  SET(LIBNL_LIBS -lnl)
+ENDIF()
+
 IF("${CMAKE_SYSTEM_NAME}" MATCHES "Linux" AND NOT DUMMY_MODE)
        SET(SOURCES ${SOURCES} system-linux.c)
-       SET(LIBS ${LIBS} nl)
+       SET(LIBS ${LIBS} ${LIBNL_LIBS})
 ELSE()
        ADD_DEFINITIONS(-DDUMMY_MODE=1)
        SET(SOURCES ${SOURCES} system-dummy.c)
@@ -35,3 +39,7 @@ ENDIF()
 ADD_EXECUTABLE(netifd ${SOURCES})
 
 TARGET_LINK_LIBRARIES(netifd ${LIBS})
+
+INSTALL(TARGETS netifd
+       RUNTIME DESTINATION sbin
+)