only use -g3 with -DDEBUG
[project/netifd.git] / CMakeLists.txt
index 43ced00..6da39df 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(netifd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
+ADD_DEFINITIONS(-Os -Wall -Werror)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
@@ -11,7 +11,7 @@ IF(APPLE)
 ENDIF()
 
 IF(DEBUG)
-  ADD_DEFINITIONS(-DDEBUG -O0)
+  ADD_DEFINITIONS(-DDEBUG -O0 --std=gnu99 -g3)
 ENDIF()
 
 
@@ -21,4 +21,4 @@ ADD_EXECUTABLE(netifd
        config.c device.c bridge.c vlan.c ubus.c
        system-dummy.c)
 
-TARGET_LINK_LIBRARIES(netifd ubox ubus uci json)
+TARGET_LINK_LIBRARIES(netifd ubox ubus uci json blobmsg_json)