From: Steven Barth Date: Sun, 27 Apr 2008 20:53:32 +0000 (+0000) Subject: * Reworked Theme "Fledermaus" X-Git-Tag: 0.8.0~1097 X-Git-Url: https://git.archive.openwrt.org/?p=project%2Fluci.git;a=commitdiff_plain;h=2724aa14f35dd5ff44dd96b8bdb17965193d700c * Reworked Theme "Fledermaus" * Added Freifunk wizard * Added Freifunk iptables rules --- diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile index aba1509e9..8f0581206 100644 --- a/contrib/package/ffluci/Makefile +++ b/contrib/package/ffluci/Makefile @@ -26,7 +26,7 @@ define Package/ffluci CATEGORY:=Administration TITLE:=FFLuCI SUBMENU:=FFLuCI - DEPENDS:=+luaposix +haserl-lua +ffluci-system-addons + DEPENDS:=+luaposix +haserl-lua +ffluci-system-addons +ffluci-splash MAINTAINER:=Steven Barth endef @@ -61,6 +61,7 @@ define Package/ffluci/install $(CP) $(PKG_BUILD_DIR)/module/admin-core/dist/* $(1)/usr/lib/lua/ffluci/ -R $(CP) $(PKG_BUILD_DIR)/module/admin-core/contrib/uci/luci_fw $(1)/etc/config/luci_fw $(INSTALL_BIN) $(PKG_BUILD_DIR)/module/admin-core/contrib/init.d/luci_fw $(1)/etc/init.d/luci_fw + $(INSTALL_BIN) $(PKG_BUILD_DIR)/module/admin-core/contrib/init.d/luci_freifunk $(1)/etc/init.d/luci_freifunk $(INSTALL_BIN) $(PKG_BUILD_DIR)/module/admin-core/contrib/ffluci-flash $(1)/sbin $(INSTALL_BIN) $(PKG_BUILD_DIR)/module/admin-core/contrib/luci-splash $(1)/www/cgi-bin diff --git a/core/contrib/uci/freifunk b/core/contrib/uci/freifunk index 128267d04..aba12e636 100644 --- a/core/contrib/uci/freifunk +++ b/core/contrib/uci/freifunk @@ -13,4 +13,14 @@ config public community option essid halle.freifunk.net option bssid 02:CA:FF:EE:BA:BE option realm netz.freifunk-halle.net - option pool 104.62.0.0/16 \ No newline at end of file + option channel 1 + option net 104.0.0.0 + option mask 255.0.0.0 + option dhcp 10.0.0.0 + option dhcpmask 255.255.255.0 + option dns "88.198.178.18 141.54.1.1 212.204.49.83 208.67.220.220 208.67.222.222" + +config settings routing + option internal 0 + option internet 0 + \ No newline at end of file diff --git a/core/contrib/uci/luci b/core/contrib/uci/luci index 292e8f2b2..3e8dcc89a 100644 --- a/core/contrib/uci/luci +++ b/core/contrib/uci/luci @@ -25,6 +25,7 @@ config event uci_oncommit option fstab "/etc/init.d/fstab restart" option qos "/etc/init.d/qos restart" option luci_splash "/etc/init.d/luci_splash restart" + option freifunk "/etc/init.d/luci_freifunk restart" config internal languages option de "Deutsch" diff --git a/core/src/ffluci/view/cbi/map.htm b/core/src/ffluci/view/cbi/map.htm index 83c377fb8..835393c1c 100644 --- a/core/src/ffluci/view/cbi/map.htm +++ b/core/src/ffluci/view/cbi/map.htm @@ -1,7 +1,6 @@

<%=self.title%>

<%=self.description%>
-
<% self:render_children() %>
diff --git a/core/src/ffluci/view/cbi/nsection.htm b/core/src/ffluci/view/cbi/nsection.htm index 0f7601a94..bbc87f185 100644 --- a/core/src/ffluci/view/cbi/nsection.htm +++ b/core/src/ffluci/view/cbi/nsection.htm @@ -3,7 +3,7 @@ section = self.section %>

<%=self.title%>

<%=self.description%>
- <% if self.addremove then %>
+ <% if self.addremove then %>
<% end %> <%+cbi/ucisection%> diff --git a/core/src/ffluci/view/cbi/ucisection.htm b/core/src/ffluci/view/cbi/ucisection.htm index ef1b6cb0e..a1fb39cf4 100644 --- a/core/src/ffluci/view/cbi/ucisection.htm +++ b/core/src/ffluci/view/cbi/ucisection.htm @@ -1,4 +1,4 @@ -
+
<% self:render_children(section) %> <% if #self.optionals[section] > 0 or self.dynamic then %>
@@ -19,5 +19,5 @@
<% end %> -
+

\ No newline at end of file diff --git a/core/src/ffluci/view/cbi/valuefooter.htm b/core/src/ffluci/view/cbi/valuefooter.htm index 3f92f09e2..6151a3a66 100644 --- a/core/src/ffluci/view/cbi/valuefooter.htm +++ b/core/src/ffluci/view/cbi/valuefooter.htm @@ -1,4 +1,4 @@ -
<%=self.description%>
+
<%=self.description%> 
<% if self.tag_invalid[section] then %>
<%:cbi_invalid Fehler: Ungültige Eingabe%>
<% end %> diff --git a/core/src/ffluci/view/cbi/valueheader.htm b/core/src/ffluci/view/cbi/valueheader.htm index 86c782d71..062efa2dd 100644 --- a/core/src/ffluci/view/cbi/valueheader.htm +++ b/core/src/ffluci/view/cbi/valueheader.htm @@ -1,3 +1,3 @@ -
"> -
<%=self.title%>
+
"> +
<%=self.title%>
\ No newline at end of file diff --git a/module/admin-core/contrib/init.d/luci_freifunk b/module/admin-core/contrib/init.d/luci_freifunk new file mode 100644 index 000000000..dbb346f0e --- /dev/null +++ b/module/admin-core/contrib/init.d/luci_freifunk @@ -0,0 +1,68 @@ +#!/bin/sh /etc/rc.common +START=70 + +start() { + include /lib/network + scan_interfaces + + + ### Read interface names + config_get wanif wan ifname + config_get lanif lan ifname + config_get ffif ff ifname + + + [ -n "$ffif" ] || return 0 + + + ### Read from config + config_load freifunk + + config_get_bool internal routing internal + [ -n "$wanif" ] && config_get_bool internet routing internal + + + ### Freifunk to Freifunk + [ "$internal" -gt 0 ] && { + iptables -A forwarding_rule -i "$ffif" -o "$ffif" -j ACCEPT + } + + ### Lan to Freifunk + [ -n "$lanif" ] && { + iptables -A forwarding_rule -i "$lanif" -o "$ffif" -j ACCEPT + iptables -t nat -A postrouting_rule -i "$lanif" -o "$ffif" -j MASQUERADE + } + + ### Freifunk to Wan + [ "$internet" -gt 0 ] && { + iptables -A forwarding_rule -i "$ffif" -o "$wanif" -j ACCEPT + iptables -t nat -A postrouting_rule -i "$ffif" -o "$wanif" -j MASQUERADE + } +} + +stop() { + include /lib/network + scan_interfaces + + ### Read interface names + config_get wanif wan ifname + config_get lanif lan ifname + config_get ffif ff ifname + + [ -n "$ffif" ] || return 0 + + ### Freifunk to Freifunk + iptables -D forwarding_rule -i "$ffif" -o "$ffif" -j ACCEPT + + ### Lan to Freifunk + [ -n "$lanif" ] && { + iptables -D forwarding_rule -i "$lanif" -o "$ffif" -j ACCEPT + iptables -t nat -D postrouting_rule -i "$lanif" -o "$ffif" -j MASQUERADE + } + + ### Freifunk to Wan + [ -n "$wanif" -gt 0 ] && { + iptables -D forwarding_rule -i "$ffif" -o "$wanif" -j ACCEPT + iptables -t nat -D postrouting_rule -i "$ffif" -o "$wanif" -j MASQUERADE + } +} diff --git a/module/admin-core/src/controller/admin/index.lua b/module/admin-core/src/controller/admin/index.lua index b4a7720f8..685478edd 100644 --- a/module/admin-core/src/controller/admin/index.lua +++ b/module/admin-core/src/controller/admin/index.lua @@ -1 +1,127 @@ -module("ffluci.controller.admin.index", package.seeall) \ No newline at end of file +module("ffluci.controller.admin.index", package.seeall) + +function action_wizard() + if ffluci.http.formvalue("ip") then + return configure_freifunk() + end + + local ifaces = {} + local wldevs = ffluci.model.uci.show("wireless") + + if wldevs then + for k, v in pairs(wldevs.wireless) do + if v[".type"] == "wifi-device" then + table.insert(ifaces, k) + end + end + end + + ffluci.template.render("admin_index/wizard", {ifaces=ifaces}) +end + +function configure_freifunk() + local ip = ffluci.http.formvalue("ip") + local uci = ffluci.model.uci.Session() + + -- Configure FF-Interface + uci:del("network", "ff") + uci:del("network", "ffdhcp") + + uci:set("network", "ff", nil, "interface") + uci:set("network", "ff", "type", "bridge") + uci:set("network", "ff", "proto", "static") + uci:set("network", "ff", "ipaddr", ip) + uci:set("network", "ff", "netmask", uci:get("freifunk", "community", "mask")) + uci:set("network", "ff", "dns", uci:get("freifunk", "community", "dns")) + + -- Enable internal routing + uci:set("freifunk", "routing", "internal", "1") + + -- Enable internet routing + if ffluci.http.formvalue("shareinet") then + uci:set("freifunk", "routing", "internet", "1") + else + uci:set("freifunk", "routing", "internet", "0") + end + + -- Configure DHCP + if ffluci.http.formvalue("dhcp") then + local dhcpnet = uci:get("freifunk", "community", "dhcp"):match("^([0-9]+)") + local dhcpip = ip:gsub("^[0-9]+", dhcpnet) + + uci:set("network", "ffdhcp", nil, "interface") + uci:set("network", "ffdhcp", "proto", "static") + uci:set("network", "ffdhcp", "ifname", "br-ff:dhcp") + uci:set("network", "ffdhcp", "ipaddr", dhcpip) + uci:set("network", "ffdhcp", "netmask", uci:get("freifunk", "community", "dhcpmask")) + end + + -- Configure OLSR + if ffluci.http.formvalue("olsr") and uci:show("olsr") then + for k, v in pairs(uci:show("olsr").olsr) do + if v[".type"] == "Interface" or v[".type"] == "LoadPlugin" then + uci:del("olsr", "k") + end + end + + if ffluci.http.formvalue("shareinet") then + uci:set("olsr", "dyn_gw", nil, "LoadPlugin") + uci:set("olsr", "dyn_gw", "Library", "olsrd_dyn_gw.so.0.4") + end + + uci:set("olsr", "nameservice", nil, "LoadPlugin") + uci:set("olsr", "nameservice", "Library", "olsrd_nameservice.so.0.3") + uci:set("olsr", "nameservice", "name", ip:gsub("%.", "-")) + uci:set("olsr", "nameservice", "hosts_file", "/var/etc/hosts") + uci:set("olsr", "nameservice", "suffix", ".olsr") + uci:set("olsr", "nameservice", "latlon_infile", "/tmp/latlon.txt") + + uci:set("olsr", "txtinfo", nil, "LoadPlugin") + uci:set("olsr", "txtinfo", "Library", "olsrd_txtinfo.so.0.1") + uci:set("olsr", "txtinfo", "Accept", "127.0.0.1") + + local oif = uci:add("olsr", "Interface") + uci:set("olsr", oif, "Interface", "ff") + uci:set("olsr", oif, "HelloInterval", "6.0") + uci:set("olsr", oif, "HelloValidityTime", "108.0") + uci:set("olsr", oif, "TcInterval", "4.0") + uci:set("olsr", oif, "TcValidityTime", "324.0") + uci:set("olsr", oif, "MidInterval", "18.0") + uci:set("olsr", oif, "MidValidityTime", "324.0") + uci:set("olsr", oif, "HnaInterval", "18.0") + uci:set("olsr", oif, "HnaValidityTime", "108.0") + end + + -- Configure Wifi + local wifi = ffluci.http.formvalue("wifi") + local wcfg = uci:show("wireless") + if type(wifi) == "table" and wcfg then + for iface, v in pairs(wifi) do + if wcfg[iface] then + -- Cleanup + for k, v in pairs(wcfg.wireless) do + if v[".type"] == "wifi-iface" and v.device == iface then + uci:del("wireless", k) + end + end + + uci:set("wireless", iface, "disabled", "0") + uci:set("wireless", iface, "mode", "11g") + uci:set("wireless", iface, "txantenna", 1) + uci:set("wireless", iface, "rxantenna", 1) + uci:set("wireless", iface, "channel", uci:get("freifunk", "community", "channel")) + + local wif = uci:add("wireless", "wifi-iface") + uci:set("wireless", wif, "device", iface) + uci:set("wireless", wif, "network", "ff") + uci:set("wireless", wif, "mode", "adhoc") + uci:set("wireless", wif, "ssid", uci:get("freifunk", "community", "essid")) + uci:set("wireless", wif, "bssid", uci:get("freifunk", "community", "bssid")) + uci:set("wireless", wif, "txpower", 13) + end + end + end + + + ffluci.http.request_redirect("admin", "uci", "changes") +end \ No newline at end of file diff --git a/module/admin-core/src/model/cbi/admin_index/freifunk.lua b/module/admin-core/src/model/cbi/admin_index/freifunk.lua index 64e916f32..ec4d100b8 100644 --- a/module/admin-core/src/model/cbi/admin_index/freifunk.lua +++ b/module/admin-core/src/model/cbi/admin_index/freifunk.lua @@ -1,13 +1,23 @@ -- Todo: Translate -m = Map("freifunk", "Freifunk", [[Informationen über die lokale Freifunkgemeinschaft.]]) +m = Map("freifunk", "Freifunk") -c = m:section(NamedSection, "community", "public") +s = m:section(NamedSection, "routing", "settings", "Netzverkehr") +s:option(Flag, "internal", "Freifunk zulassen", "immer aktivieren!") +s:option(Flag, "internet", "Internet zulassen") +c = m:section(NamedSection, "community", "public", "Gemeinschaft", [[Dies sind die Grundeinstellungen +für die lokale Freifunkgemeinschaft. Diese Werte wirken sich NICHT auf die Konfiguration +des Routers aus, sondern definieren nur die Vorgaben für den Freifunkassistenten.]]) c:option(Value, "name", "Gemeinschaft") c:option(Value, "homepage", "Webseite") c:option(Value, "essid", "ESSID") c:option(Value, "bssid", "BSSID") +c:option(Value, "channel", "Funkkanal") c:option(Value, "realm", "Realm") -c:option(Value, "pool", "Adressbereich") +c:option(Value, "net", "Adressbereich") +c:option(Value, "mask", "Netzmaske") +c:option(Value, "dns", "DNS-Server") +c:option(Value, "dhcp", "DHCP-Bereich") +c:option(Value, "dhcpmask", "DHCP-Maske") return m \ No newline at end of file diff --git a/module/admin-core/src/model/menu/00admin.lua b/module/admin-core/src/model/menu/00admin.lua index 7d56b8b54..8f87792ca 100644 --- a/module/admin-core/src/model/menu/00admin.lua +++ b/module/admin-core/src/model/menu/00admin.lua @@ -1,4 +1,5 @@ add("admin", "index", "Übersicht", 10) +act("wizard", "Freifunkassistent") act("contact", "Kontakt") act("luci", "Oberfläche") act("freifunk", "Freifunk") diff --git a/module/admin-core/src/view/admin_index/wizard.htm b/module/admin-core/src/view/admin_index/wizard.htm new file mode 100644 index 000000000..8c1a0952b --- /dev/null +++ b/module/admin-core/src/view/admin_index/wizard.htm @@ -0,0 +1,36 @@ +<%+header%> +

<%:ffwizard Freifunkassistent%>

+

<%:ffwizard1 Dieser Assistent konfiguriert den Router für die Benutzung im Freifunknetz%>

+
+
+
+
+
<%:ip IP-Adresse%>:  +
+
+ <% for i, k in ipairs(ifaces) do %> +
+
<%:wificfg Drahtlosgerät einrichten%>: <%=k%>
+
+
+ <% end %> +
+
<%:cfgolsr OLSR konfigurieren%>
+
+
+
+
<%:cfgdhcp Drahtlos DHCP konfigurieren%>
+
+
+
+
<%:shareinet Internet teilen%>
+
+
+
+
+
+ + +
+
+<%+footer%> \ No newline at end of file diff --git a/module/admin-core/src/view/admin_system/ipkg.htm b/module/admin-core/src/view/admin_system/ipkg.htm index c1f6ad0be..a385e8327 100644 --- a/module/admin-core/src/view/admin_system/ipkg.htm +++ b/module/admin-core/src/view/admin_system/ipkg.htm @@ -10,7 +10,7 @@
-
+

@@ -18,6 +18,6 @@
<% if msg then %>
<%:error Fehler%>: <%=msg%>
<% end %> -
+
<%+footer%> \ No newline at end of file diff --git a/module/admin-core/src/view/admin_system/passwd.htm b/module/admin-core/src/view/admin_system/passwd.htm index e736204bb..10a079945 100644 --- a/module/admin-core/src/view/admin_system/passwd.htm +++ b/module/admin-core/src/view/admin_system/passwd.htm @@ -14,7 +14,7 @@ <% end %> <% if not stat or stat == 10 then %>
-
+
<%:password Passwort%>
@@ -28,7 +28,7 @@
-
+
<% end %>
diff --git a/module/admin-core/src/view/admin_system/sshkeys.htm b/module/admin-core/src/view/admin_system/sshkeys.htm index 9cf91f998..ad80b63f0 100644 --- a/module/admin-core/src/view/admin_system/sshkeys.htm +++ b/module/admin-core/src/view/admin_system/sshkeys.htm @@ -10,7 +10,7 @@
-
+

@@ -18,6 +18,6 @@
<% if msg then %>
<%:error Fehler%>: <%=msg%>
<% end %> -
+
<%+footer%> \ No newline at end of file diff --git a/module/admin-core/src/view/admin_system/upgrade.htm b/module/admin-core/src/view/admin_system/upgrade.htm index 35f2e8141..598002890 100644 --- a/module/admin-core/src/view/admin_system/upgrade.htm +++ b/module/admin-core/src/view/admin_system/upgrade.htm @@ -6,7 +6,7 @@ Das Format der Firmware ist plattformabhängig.%>


<% if sysupgrade and not ret then %>
-
+
<%:fwimage Firmwareimage%>
@@ -20,7 +20,7 @@ Das Format der Firmware ist plattformabhängig.%>

-
+
<% elseif ret then %> <% if ret == 0 then %> diff --git a/themes/fledermaus/contrib/media/cascade.css b/themes/fledermaus/contrib/media/cascade.css index ad1de6f46..a7245ae60 100644 --- a/themes/fledermaus/contrib/media/cascade.css +++ b/themes/fledermaus/contrib/media/cascade.css @@ -196,14 +196,21 @@ table th, table, td { text-align: right; } +.cbi-value { + display: table-row; +} + .cbi-value-title { + display: table-cell; line-height: 1.75em; - width: 15em; font-weight: bold; + padding: 0.25em; } .cbi-value-field { + display: table-cell; text-align: left; + padding: 0.25em; line-height: 1.75em; } @@ -219,8 +226,10 @@ table th, table, td { } .cbi-value-description { + display: inline; font-style: italic; font-size: 0.8em; + padding: 0.25em; margin-bottom: 0.5em; } @@ -229,11 +238,10 @@ table th, table, td { } .cbi-section-node { - display: block; + display: table; + padding: 0.25em; background: #f7f7f7; border: 1px solid #d7d7d7; - overflow: auto; - margn-bottom: 0%; } .cbi-section-node h3 { diff --git a/themes/fledermaus/contrib/media/cbi.js b/themes/fledermaus/contrib/media/cbi.js index f9e463bca..a3a47aa45 100644 --- a/themes/fledermaus/contrib/media/cbi.js +++ b/themes/fledermaus/contrib/media/cbi.js @@ -16,15 +16,21 @@ function cbi_d_update(target) { } for (var x in cbi_d[target]) { - for (var i=0; i