meshwizard: cleanup references to madwifi 997/head
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 28 Feb 2017 16:57:31 +0000 (18:57 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Tue, 28 Feb 2017 16:57:31 +0000 (18:57 +0200)
Remove the code related to the deprecated madwifi driver.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
applications/luci-app-meshwizard/luasrc/model/cbi/freifunk/meshwizard.lua
contrib/package/meshwizard/Makefile
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/rename-wifi.sh
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/setup_wifi.sh
contrib/package/meshwizard/files/usr/bin/meshwizard/helpers/supports_vap.sh

index 68f7a5a..62ce25e 100644 (file)
@@ -103,10 +103,7 @@ uci:foreach("wireless", "wifi-device", function(section)
 
        -- Channel selection
 
-       if hwtype == "atheros" then
-               local cc = util.trim(sys.exec("grep -i '" .. syscc .. "' /lib/wifi/cc_translate.txt |cut -d ' ' -f 2")) or 0
-               sys.exec('"echo " .. cc .. " > /proc/sys/dev/" .. device .. "/countrycode"')
-       elseif hwtype == "mac80211" then
+       if hwtype == "mac80211" then
                sys.exec("iw reg set " .. syscc)
        elseif hwtype == "broadcom" then
                sys.exec ("wlc country " .. syscc)
index 9ac5a06..6298346 100644 (file)
@@ -4,7 +4,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meshwizard
-PKG_RELEASE:=0.3.2
+PKG_RELEASE:=0.3.3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index e9139ed..f2d10cc 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 # This script renames IB_wifi_ interface names into real interface names used on this system.
-# E.g. wireless.IB_wifi0 would become wireless.wifi0 on madwifi and wireless.radio0 on mac80211
+# E.g. wireless.IB_wifi0 would become wireless.radio0 on mac80211
 
 . $dir/functions.sh
 
index 41feb86..707b7b7 100755 (executable)
@@ -59,11 +59,6 @@ uci set wireless.$net\_iface=wifi-iface
 # create new wifi-iface for $net from defaults
 set_defaults "wifi_iface_" wireless.$net\_iface
 
-# overwrite some settings for type atheros (madwifi)
-if [ "$type" = "atheros" ]; then
-       set_defaults "madwifi_wifi_iface_" wireless.${net}
-fi
-
 # overwrite defaults
 bssid="$($dir/helpers/gen_bssid.sh $channel $community)"
 
index 0585ab5..7fdff3c 100755 (executable)
@@ -8,9 +8,7 @@ if [ -z "$dev" -o -z "$type" ]; then
        exit 1
 fi
 
-if [ "$type" = "atheros" ]; then
-        exit 0
-elif [ "$type" = "mac80211" ]; then
+if [ "$type" = "mac80211" ]; then
        # not hostapd[-mini], no VAP
        if [ ! -x /usr/sbin/hostapd ]; then
                echo "WARNING: hostapd[-mini] is required to be able to use VAP with mac80211."