luanet doesn't compile on Darwin
authorSteven Barth <steven@midlink.org>
Mon, 10 Aug 2009 09:16:32 +0000 (09:16 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 10 Aug 2009 09:16:32 +0000 (09:16 +0000)
libs/luanet/Makefile

index 702f866..96ec960 100644 (file)
@@ -7,12 +7,14 @@ include ../../build/config.mk
 include ../../build/gccconfig.mk
 
 compile: 
 include ../../build/gccconfig.mk
 
 compile: 
+ifneq ($(OS),Darwin)
        make -Csrc \
                CFLAGS="$(CFLAGS) $(FPIC) $(LUA_CFLAGS) $(EXTRA_CFLAGS)" \
                LDFLAGS="$(LDFLAGS)" \
                MYLDFLAGS="$(MYLDFLAGS)"
        mkdir -p dist/usr/lib/lua/
        cp src/luanet.so dist/usr/lib/lua
        make -Csrc \
                CFLAGS="$(CFLAGS) $(FPIC) $(LUA_CFLAGS) $(EXTRA_CFLAGS)" \
                LDFLAGS="$(LDFLAGS)" \
                MYLDFLAGS="$(MYLDFLAGS)"
        mkdir -p dist/usr/lib/lua/
        cp src/luanet.so dist/usr/lib/lua
+endif
 
 clean: luaclean
        make -Csrc clean
 
 clean: luaclean
        make -Csrc clean