contrib: make lua host build dependency conditional
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Nov 2009 02:52:47 +0000 (02:52 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 Nov 2009 02:52:47 +0000 (02:52 +0000)
contrib/package/luci/Makefile

index 81221a6..82c3ecf 100644 (file)
@@ -23,7 +23,7 @@ else
   PKG_SOURCE_VERSION:=$(PKG_REV)
 endif
 
   PKG_SOURCE_VERSION:=$(PKG_REV)
 endif
 
-PKG_BUILD_DEPENDS:=lua/host
+PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install