luci/lpk: Initial commit
authorSteven Barth <steven@midlink.org>
Sat, 26 Jul 2008 22:29:09 +0000 (22:29 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 26 Jul 2008 22:29:09 +0000 (22:29 +0000)
libs/lpk/Makefile [new file with mode: 0644]
libs/lpk/luasrc/lpk.lua [new file with mode: 0644]
libs/lpk/luasrc/lpk/state.lua [new file with mode: 0644]
libs/lpk/luasrc/lpk/state/install.lua [new file with mode: 0644]
libs/lpk/luasrc/lpk/state/resolve.lua [new file with mode: 0644]
libs/lpk/luasrc/lpk/state/retreive.lua [new file with mode: 0644]

diff --git a/libs/lpk/Makefile b/libs/lpk/Makefile
new file mode 100644 (file)
index 0000000..f7fac77
--- /dev/null
@@ -0,0 +1,2 @@
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/libs/lpk/luasrc/lpk.lua b/libs/lpk/luasrc/lpk.lua
new file mode 100644 (file)
index 0000000..fc22354
--- /dev/null
@@ -0,0 +1,38 @@
+module("luci.lpk", package.seeall)
+
+function getopt( arg, options )
+       local tab = {}
+       local args = {}
+       for k, v in ipairs(arg) do
+       if v:sub(1, 2) == "--" then
+               local x = v:find( "=", 1, true )
+               if x then
+                       tab[ v:sub( 3, x-1 ) ] = v:sub( x+1 )
+               else 
+                   tab[ v:sub( 3 ) ] = true
+               end
+       elseif v:sub( 1, 1 ) == "-" then
+               local y = 2
+               local l = #v
+               local jopt
+               while ( y <= l ) do
+                       jopt = v:sub( y, y )
+                       if options:find( jopt, 1, true ) then
+                               if y < l then
+                                       tab[ jopt ] = v:sub( y+1 )
+                                       y = l
+                               else
+                                       tab[ jopt ] = arg[ k + 1 ]
+                               end
+                       else
+                               tab[ jopt ] = true
+                       end
+                       y = y + 1
+               end
+    else 
+       table.insert(args, v)
+    end
+  end
+  return tab, args
+end
+
diff --git a/libs/lpk/luasrc/lpk/state.lua b/libs/lpk/luasrc/lpk/state.lua
new file mode 100644 (file)
index 0000000..29765de
--- /dev/null
@@ -0,0 +1,25 @@
+module("luci.lpk.state", package.seeall)
+require("luci.util")
+
+State = luci.util.class()
+
+function State.__init__()
+       self.poststates = {}
+       self.prestates  = {}
+end
+
+function State.add_poststate(state)
+       table.insert(self.poststates, state)
+end
+
+function State.add_prestate(state)
+       table.insert(self.prestates, state)
+end
+
+function State.process()
+
+end
+
+function State.handle()
+
+end
diff --git a/libs/lpk/luasrc/lpk/state/install.lua b/libs/lpk/luasrc/lpk/state/install.lua
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/libs/lpk/luasrc/lpk/state/resolve.lua b/libs/lpk/luasrc/lpk/state/resolve.lua
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/libs/lpk/luasrc/lpk/state/retreive.lua b/libs/lpk/luasrc/lpk/state/retreive.lua
new file mode 100644 (file)
index 0000000..e69de29