luci-mod-admin-full: fix luci-bwc compilation
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 11 Jan 2015 15:22:12 +0000 (16:22 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 11 Jan 2015 15:22:20 +0000 (16:22 +0100)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
modules/luci-mod-admin-full/src/Makefile

index 47045fc..d6ed8c6 100644 (file)
@@ -5,7 +5,7 @@ clean:
        rm -f luci-bwc *.o
 
 luci-bwc: luci-bwc.o
        rm -f luci-bwc *.o
 
 luci-bwc: luci-bwc.o
-       $(CC) $(LDFLAGS) -shared -o $@ $^
+       $(CC) $(LDFLAGS) -o $@ $^ -ldl
 
 compile: luci-bwc
 
 
 compile: luci-bwc