Merge pull request #740 from mkresin/master
authorHannu Nyman <hannu.nyman@iki.fi>
Sun, 12 Jun 2016 10:58:58 +0000 (13:58 +0300)
committerGitHub <noreply@github.com>
Sun, 12 Jun 2016 10:58:58 +0000 (13:58 +0300)
luci-app-ddns: pass the is_glue option value to the helper

applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua

index 009c0b9..7a09af0 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.4
+PKG_VERSION:=2.4.5
 
 # Release == build
 # increase on changes of translation files
index 6d75940..d6ccf9c 100755 (executable)
@@ -190,9 +190,11 @@ local function _get_status()
                local dnsserver = s["dns_server"] or ""
                local force_ipversion = tonumber(s["force_ipversion"] or 0)
                local force_dnstcp = tonumber(s["force_dnstcp"] or 0)
+               local is_glue = tonumber(s["is_glue"] or 0)
                local command = [[/usr/lib/ddns/dynamic_dns_lucihelper.sh]]
                command = command .. [[ get_registered_ip ]] .. lookup_host .. [[ ]] .. use_ipv6 ..
-                       [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp .. [[ ]] .. dnsserver
+                       [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp .. [[ ]] .. dnsserver ..
+                       [[ ]] .. is_glue
                local reg_ip = SYS.exec(command)
                if reg_ip == "" then
                        reg_ip = "_nodata_"