luci-app-ddns: adapt to support khost (Knot DNS) and drill (ddns-scripts 2.7.1) 715/head
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sun, 8 May 2016 17:26:53 +0000 (19:26 +0200)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sun, 8 May 2016 17:26:53 +0000 (19:26 +0200)
adapt to support khost (Knot DNS) and drill (ddns-scripts 2.7.1)

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua
applications/luci-app-ddns/luasrc/model/cbi/ddns/hints.lua
applications/luci-app-ddns/luasrc/tools/ddns.lua
applications/luci-app-ddns/po/de/ddns.po
applications/luci-app-ddns/po/templates/ddns.pot

index 6597a89..009c0b9 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.3
+PKG_VERSION:=2.4.4
 
 # Release == build
 # increase on changes of translation files
 
 # Release == build
 # increase on changes of translation files
index 652c244..6d75940 100755 (executable)
@@ -18,11 +18,11 @@ local UTIL = require "luci.util"
 local DDNS = require "luci.tools.ddns"         -- ddns multiused functions
 
 local srv_name    = "ddns-scripts"
 local DDNS = require "luci.tools.ddns"         -- ddns multiused functions
 
 local srv_name    = "ddns-scripts"
-local srv_ver_min = "2.6.3"                    -- minimum version of service required
+local srv_ver_min = "2.7.1"                    -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.4.2-1"
+local app_version = "2.4.4-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
index 32ad3c3..1f5ad68 100644 (file)
@@ -66,9 +66,9 @@ if not DDNS.has_ssl then
        sl.rawhtml  = true
        sl.title = bold_on ..
                translate("HTTPS not supported") .. bold_off
        sl.rawhtml  = true
        sl.title = bold_on ..
                translate("HTTPS not supported") .. bold_off
-       sl.value = translate("Neither GNU Wget with SSL nor cURL installed to support updates via HTTPS protocol.") ..
+       sl.value = translate("Neither GNU Wget with SSL nor cURL installed to support secure updates via HTTPS protocol.") ..
                        "<br />- " ..
                        "<br />- " ..
-                       translate("You should install GNU Wget with SSL (preferred) or cURL package.") ..
+                       translate("You should install 'wget' or 'curl' or 'uclient-fetch' with 'libustream-*ssl' package.") ..
                        "<br />- " ..
                        translate("In some versions cURL/libcurl in OpenWrt is compiled without proxy support.")
 end
                        "<br />- " ..
                        translate("In some versions cURL/libcurl in OpenWrt is compiled without proxy support.")
 end
@@ -82,7 +82,7 @@ if not DDNS.has_bindnet then
                translate("Binding to a specific network not supported") .. bold_off
        bn.value = translate("Neither GNU Wget with SSL nor cURL installed to select a network to use for communication.") ..
                        "<br />- " ..
                translate("Binding to a specific network not supported") .. bold_off
        bn.value = translate("Neither GNU Wget with SSL nor cURL installed to select a network to use for communication.") ..
                        "<br />- " ..
-                       translate("You should install GNU Wget with SSL or cURL package.") ..
+                       translate("You should install 'wget' or 'curl' package.") ..
                        "<br />- " ..
                        translate("GNU Wget will use the IP of given network, cURL will use the physical interface.") ..
                        "<br />- " ..
                        "<br />- " ..
                        translate("GNU Wget will use the IP of given network, cURL will use the physical interface.") ..
                        "<br />- " ..
@@ -98,7 +98,7 @@ if not DDNS.has_proxy then
                translate("cURL without Proxy Support") .. bold_off
        px.value = translate("cURL is installed, but libcurl was compiled without proxy support.") ..
                        "<br />- " ..
                translate("cURL without Proxy Support") .. bold_off
        px.value = translate("cURL is installed, but libcurl was compiled without proxy support.") ..
                        "<br />- " ..
-                       translate("You should install GNU Wget with SSL or replace libcurl.") ..
+                       translate("You should install 'wget' or 'uclient-fetch' package or replace libcurl.") ..
                        "<br />- " ..
                        translate("In some versions cURL/libcurl in OpenWrt is compiled without proxy support.")
 end
                        "<br />- " ..
                        translate("In some versions cURL/libcurl in OpenWrt is compiled without proxy support.")
 end
@@ -114,11 +114,11 @@ if not DDNS.has_forceip then
                                "the IP version to use for communication with DDNS Provider!")
        if not (DDNS.has_wgetssl or DDNS.has_curl or DDNS.has_fetch) then
                value = value .. "<br />- " ..
                                "the IP version to use for communication with DDNS Provider!")
        if not (DDNS.has_wgetssl or DDNS.has_curl or DDNS.has_fetch) then
                value = value .. "<br />- " ..
-                       translate("You should install GNU Wget with SSL (preferred) or cURL or uclient-fetch package.")
+                       translate("You should install 'wget' or 'curl' or 'uclient-fetch' package.")
        end
        if not (DDNS.has_bindhost or DDNS.has_hostip) then
                value = value .. "<br />- " ..
        end
        if not (DDNS.has_bindhost or DDNS.has_hostip) then
                value = value .. "<br />- " ..
-                       translate("You should install BIND host or hostip package for DNS requests.")
+                       translate("You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package for DNS requests.")
        end
        fi.value = value
 end
        end
        fi.value = value
 end
@@ -133,7 +133,7 @@ if not DDNS.has_bindhost then
        dt.value = translate("BusyBox's nslookup and hostip do not support to specify to use TCP " ..
                                "instead of default UDP when requesting DNS server!") ..
                        "<br />- " ..
        dt.value = translate("BusyBox's nslookup and hostip do not support to specify to use TCP " ..
                                "instead of default UDP when requesting DNS server!") ..
                        "<br />- " ..
-                       translate("You should install BIND host package for DNS requests.")
+                       translate("You should install 'bind-host' or 'knot-host' or 'drill' package for DNS requests.")
 end
 
 -- nslookup compiled with musl produce problems when using
 end
 
 -- nslookup compiled with musl produce problems when using
@@ -146,7 +146,7 @@ if not DDNS.has_dnsserver then
        ds.value = translate("BusyBox's nslookup in the current compiled version " ..
                                "does not handle given DNS Servers correctly!") ..
                        "<br />- " ..
        ds.value = translate("BusyBox's nslookup in the current compiled version " ..
                                "does not handle given DNS Servers correctly!") ..
                        "<br />- " ..
-                       translate("You should install BIND host or hostip package, " ..
+                       translate("You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package, " ..
                                "if you need to specify a DNS server to detect your registered IP.")
 end
 
                                "if you need to specify a DNS server to detect your registered IP.")
 end
 
@@ -159,7 +159,7 @@ if DDNS.has_ssl and not DDNS.has_cacerts then
                translate("No certificates found") .. bold_off
        ca.value = translate("If using secure communication you should verify server certificates!") ..
                        "<br />- " ..
                translate("No certificates found") .. bold_off
        ca.value = translate("If using secure communication you should verify server certificates!") ..
                        "<br />- " ..
-                       translate("Install ca-certificates package or needed certificates " ..
+                       translate("Install 'ca-certificates' package or needed certificates " ..
                                "by hand into /etc/ssl/certs default directory")
 end
 
                                "by hand into /etc/ssl/certs default directory")
 end
 
index b326cd1..6b626b9 100755 (executable)
@@ -24,6 +24,8 @@ has_fetch     = (SYS.call( [[which uclient-fetch >/dev/null 2>&1]] ) == 0)
 has_fetchssl   = NXFS.access("/lib/libustream-ssl.so")
 has_bbwget     = (SYS.call( [[$(which wget) -V 2>&1 | grep -iqF "busybox"]] ) == 0)
 has_bindhost   = (SYS.call( [[which host >/dev/null 2>&1]] ) == 0)
 has_fetchssl   = NXFS.access("/lib/libustream-ssl.so")
 has_bbwget     = (SYS.call( [[$(which wget) -V 2>&1 | grep -iqF "busybox"]] ) == 0)
 has_bindhost   = (SYS.call( [[which host >/dev/null 2>&1]] ) == 0)
+               or (SYS.call( [[which khost >/dev/null 2>&1]] ) == 0)
+               or (SYS.call( [[which drill >/dev/null 2>&1]] ) == 0)
 has_hostip     = (SYS.call( [[which hostip >/dev/null 2>&1]] ) == 0)
 has_nslookup   = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"]] ) ~= 0)
 has_ipv6       = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
 has_hostip     = (SYS.call( [[which hostip >/dev/null 2>&1]] ) == 0)
 has_nslookup   = (SYS.call( [[$(which nslookup) localhost 2>&1 | grep -qF "(null)"]] ) ~= 0)
 has_ipv6       = (NXFS.access("/proc/net/ipv6_route") and NXFS.access("/usr/sbin/ip6tables"))
index 54c0de3..76aa18c 100644 (file)
@@ -1,15 +1,15 @@
 msgid ""
 msgstr ""
 "Project-Id-Version: luci-app-ddns 2.4.2-1\n"
 msgid ""
 msgstr ""
 "Project-Id-Version: luci-app-ddns 2.4.2-1\n"
-"POT-Creation-Date: 2016-02-29 20:55+0100\n"
-"PO-Revision-Date: 2016-03-29 19:35+0200\n"
+"POT-Creation-Date: 2016-05-08 19:10+0200\n"
+"PO-Revision-Date: 2016-05-08 19:12+0200\n"
 "Last-Translator: Christian Schönebeck <christian.schoenebeck@gmail.com>\n"
 "Language-Team: \n"
 "Language: de\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
 "Last-Translator: Christian Schönebeck <christian.schoenebeck@gmail.com>\n"
 "Language-Team: \n"
 "Language: de\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
-"X-Generator: Poedit 1.8.4\n"
+"X-Generator: Poedit 1.8.7.1\n"
 "Plural-Forms: nplurals=2; plural=(n != 1);\n"
 "X-Poedit-SourceCharset: UTF-8\n"
 "X-Poedit-Basepath: .\n"
 "Plural-Forms: nplurals=2; plural=(n != 1);\n"
 "X-Poedit-SourceCharset: UTF-8\n"
 "X-Poedit-Basepath: .\n"
@@ -367,10 +367,10 @@ msgid "Info"
 msgstr "Info"
 
 msgid ""
 msgstr "Info"
 
 msgid ""
-"Install ca-certificates package or needed certificates by hand into /etc/ssl/"
-"certs default directory"
+"Install 'ca-certificates' package or needed certificates by hand into /etc/"
+"ssl/certs default directory"
 msgstr ""
 msgstr ""
-"Installieren Sie das ca-certificate Paket oder die benötigten Zertifikate "
+"Installieren Sie das 'ca-certificates' Paket oder die benötigten Zertifikate "
 "von Hand in das Standardverzeichnis /etc/ssl/certs"
 
 msgid "Interface"
 "von Hand in das Standardverzeichnis /etc/ssl/certs"
 
 msgid "Interface"
@@ -432,14 +432,11 @@ msgstr ""
 "Kommunikation festzulegen."
 
 msgid ""
 "Kommunikation festzulegen."
 
 msgid ""
-"Neither GNU Wget with SSL nor cURL installed to support updates via HTTPS "
-"protocol."
+"Neither GNU Wget with SSL nor cURL installed to support secure updates via "
+"HTTPS protocol."
 msgstr ""
 msgstr ""
-"Weder GNU Wget mit SSL noch cURL sind installiert um Aktualisierungen über "
-"HTTPS Protokoll zu unterstützen."
-
-msgid "Network"
-msgstr "Netzwerk"
+"Weder GNU Wget mit SSL noch cURL sind installiert um sichere "
+"Aktualisierungen über HTTPS Protokoll zu unterstützen."
 
 msgid "Network on which the ddns-updater scripts will be started"
 msgstr "Netzwerk auf dem Ereignisse die ddns-updater Skripte starten"
 
 msgid "Network on which the ddns-updater scripts will be started"
 msgstr "Netzwerk auf dem Ereignisse die ddns-updater Skripte starten"
@@ -669,41 +666,48 @@ msgstr ""
 "Schreibt Meldungen ins Systemprotokoll. Kritische Fehler werden immer in das "
 "Systemprotokoll geschrieben."
 
 "Schreibt Meldungen ins Systemprotokoll. Kritische Fehler werden immer in das "
 "Systemprotokoll geschrieben."
 
-msgid "You should install BIND host or hostip package for DNS requests."
-msgstr ""
-"Sie sollten das Programmpakete BIND host oder hostip für DNS Anfragen "
-"installieren."
-
 msgid ""
 msgid ""
-"You should install BIND host or hostip package, if you need to specify a DNS "
-"server to detect your registered IP."
+"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package "
+"for DNS requests."
 msgstr ""
 msgstr ""
-"Sie sollten das BIND host oder hostIP Paket installieren, wenn Sie einen DNS-"
-"Server angeben müssen um Ihre registrierte IP zu ermitteln."
+"Sie sollten das Programmpakete 'bind-host' oder 'knot-host' oder 'drill' "
+"oder 'hostip' für DNS Anfragen installieren."
 
 
-msgid "You should install BIND host package for DNS requests."
+msgid ""
+"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
+"package, if you need to specify a DNS server to detect your registered IP."
 msgstr ""
 msgstr ""
-"Sie sollten das Programmpakete BIND host for DNS Anfragen installieren."
+"Sie sollten das Programmpakete 'bind-host' oder 'knot-host' oder 'drill' "
+"oder 'hostip' installieren, wenn Sie einen DNS Server angeben müssen um Ihre "
+"registrierte IP zu ermitteln."
 
 msgid ""
 
 msgid ""
-"You should install GNU Wget with SSL (preferred) or cURL or uclient-fetch "
-"package."
+"You should install 'bind-host' or 'knot-host' or 'drill' package for DNS "
+"requests."
 msgstr ""
 msgstr ""
-"Sie sollten das Programmpaket GNU Wget mit SSL (bevorzugt) oder cURL oder "
-"uclient-fetch installieren."
+"Sie sollten das Programmpakete 'bind-host' oder 'knot-host' oder 'drill' für "
+"DNS Anfragen installieren."
 
 
-msgid "You should install GNU Wget with SSL (preferred) or cURL package."
+msgid "You should install 'wget' or 'curl' or 'uclient-fetch' package."
 msgstr ""
 msgstr ""
-"Sie sollten das Programmpaket GNU Wget mit SSL (bevorzugt) oder cURL "
+"Sie sollten das Programmpaket 'wget' oder 'curl' oder 'uclient-fetch' "
 "installieren."
 
 "installieren."
 
-msgid "You should install GNU Wget with SSL or cURL package."
-msgstr "Sie sollten das Programmpaket GNU Wget mit SSL oder cURL installieren."
+msgid ""
+"You should install 'wget' or 'curl' or 'uclient-fetch' with 'libustream-"
+"*ssl' package."
+msgstr ""
+"Sie sollten das Programmpaket 'wget' oder 'curl' oder 'uclient-fetch' mit "
+"'libustream-*ssl' installieren."
 
 
-msgid "You should install GNU Wget with SSL or replace libcurl."
+msgid "You should install 'wget' or 'curl' package."
+msgstr "Sie sollten das Programmpaket 'wget' oder 'curl' installieren."
+
+msgid ""
+"You should install 'wget' or 'uclient-fetch' package or replace libcurl."
 msgstr ""
 msgstr ""
-"Sie sollten das Programmpaket GNU Wget mit SSL installieren oder libcurl "
-"austauschen."
+"Sie sollten das Programmpaket 'wget' oder 'uclient-fetch' installieren oder "
+"libcurl ersetzen."
 
 msgid "cURL is installed, but libcurl was compiled without proxy support."
 msgstr ""
 
 msgid "cURL is installed, but libcurl was compiled without proxy support."
 msgstr ""
index 8da949f..68aebe5 100644 (file)
@@ -298,11 +298,8 @@ msgid "Info"
 msgstr ""
 
 msgid ""
 msgstr ""
 
 msgid ""
-"Install ca-certificates package or needed certificates by hand into /etc/ssl/"
-"certs default directory"
-msgstr ""
-
-msgid "Interface"
+"Install 'ca-certificates' package or needed certificates by hand into /etc/"
+"ssl/certs default directory"
 msgstr ""
 
 msgid ""
 msgstr ""
 
 msgid ""
@@ -352,11 +349,8 @@ msgid ""
 msgstr ""
 
 msgid ""
 msgstr ""
 
 msgid ""
-"Neither GNU Wget with SSL nor cURL installed to support updates via HTTPS "
-"protocol."
-msgstr ""
-
-msgid "Network"
+"Neither GNU Wget with SSL nor cURL installed to support secure updates via "
+"HTTPS protocol."
 msgstr ""
 
 msgid "Network on which the ddns-updater scripts will be started"
 msgstr ""
 
 msgid "Network on which the ddns-updater scripts will be started"
@@ -570,29 +564,34 @@ msgid ""
 "syslog."
 msgstr ""
 
 "syslog."
 msgstr ""
 
-msgid "You should install BIND host or hostip package for DNS requests."
+msgid ""
+"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package "
+"for DNS requests."
 msgstr ""
 
 msgid ""
 msgstr ""
 
 msgid ""
-"You should install BIND host or hostip package, if you need to specify a DNS "
-"server to detect your registered IP."
+"You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
+"package, if you need to specify a DNS server to detect your registered IP."
 msgstr ""
 
 msgstr ""
 
-msgid "You should install BIND host package for DNS requests."
+msgid ""
+"You should install 'bind-host' or 'knot-host' or 'drill' package for DNS "
+"requests."
 msgstr ""
 
 msgstr ""
 
-msgid ""
-"You should install GNU Wget with SSL (preferred) or cURL or uclient-fetch "
-"package."
+msgid "You should install 'wget' or 'curl' or 'uclient-fetch' package."
 msgstr ""
 
 msgstr ""
 
-msgid "You should install GNU Wget with SSL (preferred) or cURL package."
+msgid ""
+"You should install 'wget' or 'curl' or 'uclient-fetch' with 'libustream-"
+"*ssl' package."
 msgstr ""
 
 msgstr ""
 
-msgid "You should install GNU Wget with SSL or cURL package."
+msgid "You should install 'wget' or 'curl' package."
 msgstr ""
 
 msgstr ""
 
-msgid "You should install GNU Wget with SSL or replace libcurl."
+msgid ""
+"You should install 'wget' or 'uclient-fetch' package or replace libcurl."
 msgstr ""
 
 msgid "cURL is installed, but libcurl was compiled without proxy support."
 msgstr ""
 
 msgid "cURL is installed, but libcurl was compiled without proxy support."