contrib/package: make luci-app-statistics depend on a few collectd plugins
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 16 Feb 2009 17:43:43 +0000 (17:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 16 Feb 2009 17:43:43 +0000 (17:43 +0000)
applications/luci-statistics: implement a workaround for broken permissions on /tmp

applications/luci-statistics/root/etc/init.d/luci_statistics
contrib/package/luci/Makefile

index e4da1d5..21ed41e 100755 (executable)
@@ -18,14 +18,17 @@ start() {
                ln -s ${imagepath:-/tmp/rrdimg}/ /www/rrdimg
        fi
 
                ln -s ${imagepath:-/tmp/rrdimg}/ /www/rrdimg
        fi
 
-    ### flush LuCI index cache
-    test -f /var/luci-indexcache && rm /var/luci-indexcache
+       ### flush LuCI index cache
+       test -f /var/luci-indexcache && rm /var/luci-indexcache
+
+       ### workaround broken permissions on /tmp
+       chmod 1777 /tmp
 }
 
 restart() {
 }
 
 restart() {
-        ### regenerate config / prepare environment
-        start
+       ### regenerate config / prepare environment
+       start
 
 
-        ### restart collectd
-        /etc/init.d/collectd restart
+       ### restart collectd
+       /etc/init.d/collectd restart
 }
 }
index 12aca22..cebbf99 100644 (file)
@@ -415,7 +415,11 @@ endef
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
 define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
-   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 +PACKAGE_luci-app-statistics:rrdtool1
+   +PACKAGE_luci-app-statistics:rrdtool1 \
+   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 \
+   +PACKAGE_luci-app-statistics:collectd-mod-wireless \
+   +PACKAGE_luci-app-statistics:collectd-mod-interfaces \
+   +PACKAGE_luci-app-statistics:collectd-mod-load
   TITLE:=LuCI Statistics Application
 endef
 
   TITLE:=LuCI Statistics Application
 endef