Make fixtime more reliable
authorSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 13:52:22 +0000 (13:52 +0000)
committerSteven Barth <steven@midlink.org>
Sat, 17 Jan 2009 13:52:22 +0000 (13:52 +0000)
contrib/package/luci/Makefile
modules/admin-core/root/etc/init.d/luci_fixtime

index d85a93f..3016adf 100644 (file)
@@ -283,6 +283,7 @@ endef
 
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
+       touch $(1)/etc/init.d/luci_fixtime || true
 endef
 
 
index 681d9d7..f300e45 100755 (executable)
@@ -5,7 +5,7 @@ START=05
 start() {
        cat <<' EOF' | lua -l luci.fs -l luci.util -
                if (os.time() < 1000000000) then
-                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime(luci.util.libpath())))
+                       os.execute('date -s ' .. os.date('%m%d%H%M%Y', luci.fs.mtime("/etc/init.d/luci_fixtime")))
                end
        EOF
 }