contrib/package: add qos related dependencies to luci-splash
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 10 Jun 2009 16:28:56 +0000 (16:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 10 Jun 2009 16:28:56 +0000 (16:28 +0000)
contrib/package/luci/Makefile

index f6450f1..3b3e0b4 100644 (file)
@@ -472,7 +472,8 @@ endef
 
 define Package/luci-app-olsr
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
+  DEPENDS+=+luci-admin-full +PACKAGE_luci-app-olsr:olsrd-luci \
+   +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo
   TITLE:=OLSR configuration and status module
 endef
 
@@ -494,7 +495,10 @@ endef
 
 define Package/luci-app-splash
   $(call Package/luci/fftemplate)
-  DEPENDS+=+PACKAGE_luci-app-splash:luci-nixio +PACKAGE_luci-app-splash:iptables-mod-nat-extra
+  DEPENDS+=+PACKAGE_luci-app-splash:luci-nixio \
+   +PACKAGE_luci-app-splash:tc +PACKAGE_luci-app-splash:kmod-sched \
+   +PACKAGE_luci-app-splash:iptables-mod-nat-extra \
+   +PACKAGE_luci-app-splash:iptables-mod-ipopt
   TITLE:=Freifunk DHCP-Splash application
 endef
 
@@ -687,7 +691,8 @@ endef
 define Package/luci-app-p2pblock
   $(call Package/luci/webtemplate)
   TITLE:=LuCI Support for the Freifunk P2P-Block addon
-  DEPENDS+=+luci-admin-core +luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock
+  DEPENDS+=+luci-admin-core +luci-app-firewall \
+    +PACKAGE_luci-app-p2pblock:freifunk-p2pblock
 endef
 
 define Package/luci-app-p2pblock/install