Fix IPv6 package dependencies
authorSteven Barth <steven@midlink.org>
Thu, 23 May 2013 10:13:58 +0000 (10:13 +0000)
committerSteven Barth <steven@midlink.org>
Thu, 23 May 2013 10:13:58 +0000 (10:13 +0000)
contrib/package/luci/Makefile
protocols/ipv6/luasrc/model/network/proto_dhcpv6.lua

index 86ffce7..2542544 100644 (file)
@@ -196,7 +196,7 @@ endef
 
 $(eval $(call protocol,core,Support for static/dhcp/none))
 $(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
-$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd,+PACKAGE_luci-proto-ipv6:6in4 +PACKAGE_luci-proto-ipv6:6to4 +PACKAGE_luci-proto-ipv6:6rd +PACKAGE_luci-proto-ipv6:odhcp6c))
+$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd/DS-Lite))
 $(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
 $(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
index e5e54d5..59463d1 100644 (file)
@@ -28,5 +28,5 @@ function proto.is_installed(self)
 end
 
 function proto.opkg_package(self)
-       return "ipv6-support"
+       return "odhcp6c"
 end