add "run" target
authorSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 15:34:26 +0000 (15:34 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 15:34:26 +0000 (15:34 +0000)
Makefile

index c78f5a8..ec0d76a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -37,6 +37,9 @@ hostcopy:
        mkdir -p host
        for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
        ln -sf .$(LUCI_INSTALLDIR) host/luci
        mkdir -p host
        for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
        ln -sf .$(LUCI_INSTALLDIR) host/luci
-       
+
+run: host
+       ./host/usr/bin/boa -c ./host/etc/boa -d
+
 hostclean: clean
        rm -rf host
 hostclean: clean
        rm -rf host