* Added index.html redirector
authorSteven Barth <steven@midlink.org>
Fri, 28 Mar 2008 00:10:48 +0000 (00:10 +0000)
committerSteven Barth <steven@midlink.org>
Fri, 28 Mar 2008 00:10:48 +0000 (00:10 +0000)
contrib/index.html [new file with mode: 0644]
contrib/package/ffluci/Makefile

diff --git a/contrib/index.html b/contrib/index.html
new file mode 100644 (file)
index 0000000..2c24464
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
+</head>
+<body>
+<a href="/cgi-bin/index.cgi">FFLuCI</a>
+</body>
+</html>
\ No newline at end of file
index f57a5da..04093a9 100644 (file)
@@ -40,6 +40,7 @@ define Package/ffluci/install
        $(CP) $(PKG_BUILD_DIR)/contrib/media $(1)/www/ffluci/ -R
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/ffluci $(1)/www/cgi-bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/index.cgi $(1)/www/cgi-bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/index.html $(1)/www
        $(CP) $(PKG_BUILD_DIR)/contrib/ffluci.uci $(1)/etc/config/luci
        $(CP) -a ./ipkg/ffluci.postinst $(1)/CONTROL/postinst
        $(CP) -a ./ipkg/conffiles $(1)/CONTROL/conffiles