* libs/fastindex: Changed Makefile to use LUCI_INSTALLDIR
authorSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 19:14:56 +0000 (19:14 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 2 Jun 2008 19:14:56 +0000 (19:14 +0000)
libs/fastindex/Makefile

index 560a352..d064bbd 100644 (file)
@@ -5,8 +5,8 @@ include ../../build/gccconfig.mk
        $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $< 
 
 compile: src/fastindex.o
        $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $< 
 
 compile: src/fastindex.o
-       mkdir -p dist/usr/lib/lua/luci
-       $(LINK) $(SHLIB_FLAGS) -o dist/usr/lib/lua/luci/fastindex.so src/fastindex.o $(LUA_SHLIBS)
+       mkdir -p dist$(LUCI_INSTALLDIR)
+       $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_INSTALLDIR)/fastindex.so src/fastindex.o $(LUA_SHLIBS)
 
 clean:
        rm -f src/*.o
 
 clean:
        rm -f src/*.o