build: add nixiodocs make target, remove uvldocs target
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Feb 2011 20:14:25 +0000 (20:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Feb 2011 20:14:25 +0000 (20:14 +0000)
Makefile

index ceb80ac..21c88b2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -77,9 +77,8 @@ hostclean: clean
 apidocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh host/luci/ docs"
 
-uvldocs: hostenv
-       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
-       "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
+nixiodocs: hostenv
+       build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) "build/makedocs.sh libs/nixio/ nixiodocs"
 
 po: host
        for L in $${LANGUAGE:-$$(find i18n/ -path 'i18n/*/luasrc/i18n/*' -name 'default.*.lua' | \