* Removed support for Haserl
authorSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 18:54:44 +0000 (18:54 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 18:54:44 +0000 (18:54 +0000)
12 files changed:
contrib/package-source/haserl-lua-0.9.24.tar.bz2 [deleted file]
contrib/package/haserl-lua/Makefile [deleted file]
contrib/package/haserl-lua/patches/200-bytecode-header-luci [deleted file]
contrib/package/luci/Makefile
libs/sgi-cgi/ipkg/postinst [new file with mode: 0755]
libs/sgi-haserl/Makefile [deleted file]
libs/sgi-haserl/htdocs/cgi-bin/index.cgi [deleted file]
libs/sgi-haserl/htdocs/cgi-bin/luci [deleted file]
libs/sgi-haserl/htdocs/cgi-bin/luci-upload [deleted file]
libs/sgi-haserl/htdocs/index.html [deleted file]
libs/sgi-haserl/ipkg/postinst [deleted file]
libs/sgi-haserl/luasrc/sgi/haserl.lua [deleted file]

diff --git a/contrib/package-source/haserl-lua-0.9.24.tar.bz2 b/contrib/package-source/haserl-lua-0.9.24.tar.bz2
deleted file mode 100644 (file)
index 95fdc4c..0000000
Binary files a/contrib/package-source/haserl-lua-0.9.24.tar.bz2 and /dev/null differ
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
deleted file mode 100644 (file)
index 3115821..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=haserl-lua
-PKG_VERSION:=0.9.24
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/ \
-       http://firmware.freifunk-halle.net/luci/package-source/
-PKG_MD5SUM:=b004005594b84e35839b1d5c330f8e03
-
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/haserl-lua
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=A CGI wrapper to embed shell scripts in HTML documents
-  URL:=http://haserl.sourceforge.net/
-  DEPENDS:=+liblua
-endef
-
-CONFIGURE_ARGS += \
-        --with-lua
-
-define Package/haserl-lua/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(STRIP) $(PKG_BUILD_DIR)/src/haserl
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
-       echo "Replaces: haserl" >> $(1)/CONTROL/control
-       echo "Conflicts: haserl" >> $(1)/CONTROL/control
-endef
-
-$(eval $(call BuildPackage,haserl-lua))
diff --git a/contrib/package/haserl-lua/patches/200-bytecode-header-luci b/contrib/package/haserl-lua/patches/200-bytecode-header-luci
deleted file mode 100644 (file)
index c93fe7a..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur haserl-0.9.23.orig/src/haserl_lualib.inc haserl-0.9.23/src/haserl_lualib.inc
---- haserl-0.9.23.orig/src/haserl_lualib.inc   2008-04-05 16:40:35.000000000 +0200
-+++ haserl-0.9.23/src/haserl_lualib.inc        2008-04-05 16:41:37.000000000 +0200
-@@ -1,7 +1,7 @@
- /* This file was automatically generated from haserl_lualib.lua. DO NOT EDIT */
- static const unsigned char haserl_lualib[] = { 
--   27, 76,117, 97, 81,  0,  1,  4,  4,  4,  8,  0, 19,  0,  0,  0,
-+   27, 76,117, 97, 81,  0,  1,  4,  4,  4,  8,  4, 19,  0,  0,  0,
-    64,104, 97,115,101,114,108, 95,108,117, 97,108,105, 98, 46,108,
-   117, 97,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  0,  2,  3, 16,
-     0,  0,  0, 10,  0,  0,  0, 74,  0,  0,  0,138,  0,  0,  0,135,
index 5015665..b2571f7 100644 (file)
@@ -322,17 +322,6 @@ define Package/luci-sgi-cgi/install
        $(call Package/luci/install/template,$(1),libs/sgi-cgi)
 endef
 
-define Package/luci-sgi-haserl
-  $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web +haserl-lua
-  TITLE:=SGI for Haserl
-endef
-
-define Package/luci-sgi-haserl/install
-       $(call Package/luci/install/template,$(1),libs/sgi-haserl)
-endef
-
-
 define Package/luci-sgi-webuci
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-web
@@ -441,9 +430,6 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
 endif
-ifneq ($(CONFIG_PACKAGE_luci-sgi-haserl),)
-       PKG_SELECTED_MODULES+=libs/sgi-haserl
-endif
 ifneq ($(CONFIG_PACKAGE_luci-sgi-webuci),)
        PKG_SELECTED_MODULES+=libs/sgi-webuci
 endif
@@ -487,7 +473,6 @@ $(eval $(call BuildPackage,luci-app-splash))
 $(eval $(call BuildPackage,luci-app-statistics))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
-$(eval $(call BuildPackage,luci-sgi-haserl))
 $(eval $(call BuildPackage,luci-sgi-webuci))
 
 $(eval $(call BuildPackage,luci-theme-fledermaus))
diff --git a/libs/sgi-cgi/ipkg/postinst b/libs/sgi-cgi/ipkg/postinst
new file mode 100755 (executable)
index 0000000..bbc1e53
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+[ -f "${IPKG_INSTROOT}/etc/httpd.conf" ] && { 
+       PATTERNS='/cgi-bin/luci/admin:root:$p$root'
+
+       for i in $PATTERNS
+       do
+               grep "$i" ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo "$i" >> ${IPKG_INSTROOT}/etc/httpd.conf
+       done 
+
+       [ -n "${IPKG_INSTROOT}" ] || /etc/init.d/httpd restart
+}
diff --git a/libs/sgi-haserl/Makefile b/libs/sgi-haserl/Makefile
deleted file mode 100644 (file)
index 81a96f6..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-include ../../build/config.mk
-include ../../build/module.mk
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/index.cgi b/libs/sgi-haserl/htdocs/cgi-bin/index.cgi
deleted file mode 100755 (executable)
index aae8591..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-print("Status: 302 Found")
-print("Location: luci\n")
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/luci b/libs/sgi-haserl/htdocs/cgi-bin/luci
deleted file mode 100755 (executable)
index fd8e594..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-require("luci.sgi.haserl")
-luci.dispatcher.indexcache = "/tmp/.luciindex"
-luci.sgi.haserl.run()
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/luci-upload b/libs/sgi-haserl/htdocs/cgi-bin/luci-upload
deleted file mode 100755 (executable)
index 371967c..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/haserl --shell=luac --upload-limit=16384
--- This is a bit hacky: remove -upload from SCRIPT_NAME
-ENV.SCRIPT_NAME = ENV.SCRIPT_NAME:sub(1, #ENV.SCRIPT_NAME - 7)
-dofile("luci")
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/index.html b/libs/sgi-haserl/htdocs/index.html
deleted file mode 100644 (file)
index 39ba558..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
-<html xmlns="http://www.w3.org/1999/xhtml">
-<head>
-<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
-</head>
-<body style="background-color: black">
-<a style="color: white; text-decoration: none" href="/cgi-bin/index.cgi">LuCI - Lua Configuration Interface</a>
-</body>
-</html>
\ No newline at end of file
diff --git a/libs/sgi-haserl/ipkg/postinst b/libs/sgi-haserl/ipkg/postinst
deleted file mode 100755 (executable)
index 483a086..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-PATTERNS='/cgi-bin/luci/admin:root:$p$root /cgi-bin/luci-upload:root:$p$root'
-
-for i in $PATTERNS
-do
-       grep "$i" ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo "$i" >> ${IPKG_INSTROOT}/etc/httpd.conf
-done 
-
-[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart
diff --git a/libs/sgi-haserl/luasrc/sgi/haserl.lua b/libs/sgi-haserl/luasrc/sgi/haserl.lua
deleted file mode 100644 (file)
index 88b7f00..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
---[[
-LuCI - SGI-Module for Haserl
-
-Description:
-Server Gateway Interface for Haserl
-
-FileId:
-$Id: haserl.lua 2027 2008-05-07 21:16:35Z Cyrus $
-
-License:
-Copyright 2008 Steven Barth <steven@midlink.org>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at 
-
-       http://www.apache.org/licenses/LICENSE-2.0 
-
-Unless required by applicable law or agreed to in writing, software
-distributed under the License is distributed on an "AS IS" BASIS,
-WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-See the License for the specific language governing permissions and
-limitations under the License.
-
-]]--
-module("luci.sgi.haserl", package.seeall)
-require("luci.http")
-require("luci.util")
-require("luci.dispatcher")
-
-function run()
-       local r = luci.http.Request(ENV, nil, io.stderr)
-       r.get = normalize_table(FORM)
-       r.post = r.get
-       
-       local x = coroutine.create(luci.dispatcher.httpdispatch)
-       while coroutine.status(x) ~= "dead" do
-               local res, id, data1, data2 = coroutine.resume(x, r)
-               
-               if not res then
-                       print("Status: 500 Internal Server Error")
-                       print("Content-Type: text/plain\n")
-                       print(id)
-                       break;
-               end
-               
-               if id == 1 then
-                       io.write("Status: " .. tostring(data1) .. " " .. data2 .. "\n")
-               elseif id == 2 then
-                       io.write(data1 .. ": " .. data2 .. "\n")
-               elseif id == 3 then
-                       io.write("\n")
-               elseif id == 4 then
-                       io.write(data1)
-               end
-       end
-end
-
-function normalize_table(table, prefix)
-       prefix = prefix and prefix .. "." or ""
-       local new = {}
-       
-       for k,v in pairs(table) do
-               if type(v) == "table" and #v == 0 then
-                       luci.util.update(new, normalize_table(v, prefix .. k))
-               else
-                       new[prefix .. k] = v
-               end
-       end
-       
-       return new
-end