* Made Makefiles attribute aware
authorSteven Barth <steven@midlink.org>
Mon, 9 Jun 2008 07:56:20 +0000 (07:56 +0000)
committerSteven Barth <steven@midlink.org>
Mon, 9 Jun 2008 07:56:20 +0000 (07:56 +0000)
15 files changed:
Makefile
applications/community-halle/ipkg/postinst [new file with mode: 0755]
applications/community-hannover/ipkg/postinst [new file with mode: 0755]
applications/community-leipzig/ipkg/postinst [new file with mode: 0755]
applications/luci-fw/root/etc/init.d/luci_fw [changed mode: 0644->0755]
applications/luci-statistics/ipkg/postinst [new file with mode: 0755]
applications/luci-statistics/root/etc/init.d/luci_statistics [changed mode: 0644->0755]
build/module.mk
contrib/package/luci/Makefile
contrib/package/luci/ipkg/luci-ff-halle.postinst [deleted file]
contrib/package/luci/ipkg/luci-ff-hannover.postinst [deleted file]
contrib/package/luci/ipkg/luci-ff-leipzig.postinst [deleted file]
contrib/package/luci/ipkg/luci-sgi-haserl.postinst [deleted file]
contrib/package/luci/ipkg/luci-statistics.postint [deleted file]
libs/sgi-haserl/ipkg/postinst [new file with mode: 0755]

index fa9a407..38e2d15 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -30,7 +30,7 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host
 
 hostcopy: 
        mkdir -p host
-       for i in $(MODULES); do cp $$i/dist/* host/ -R 2>/dev/null || true; done
+       for i in $(MODULES); do cp -a $$i/dist/* host/ -R 2>/dev/null || true; done
        rm -f host/luci
        ln -s .$(LUCI_INSTALLDIR) host/luci
 
        rm -f host/luci
        ln -s .$(LUCI_INSTALLDIR) host/luci
 
diff --git a/applications/community-halle/ipkg/postinst b/applications/community-halle/ipkg/postinst
new file mode 100755 (executable)
index 0000000..0efb5a9
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-community-halle ) && rm -f /etc/uci-defaults/luci-community-halle
+}
diff --git a/applications/community-hannover/ipkg/postinst b/applications/community-hannover/ipkg/postinst
new file mode 100755 (executable)
index 0000000..b41179f
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-community-hannover ) &&      rm -f /etc/uci-defaults/luci-community-hannover
+}
diff --git a/applications/community-leipzig/ipkg/postinst b/applications/community-leipzig/ipkg/postinst
new file mode 100755 (executable)
index 0000000..5aff5db
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-community-leipzig ) &&       rm -f /etc/uci-defaults/luci-community-leipzig
+}
old mode 100644 (file)
new mode 100755 (executable)
diff --git a/applications/luci-statistics/ipkg/postinst b/applications/luci-statistics/ipkg/postinst
new file mode 100755 (executable)
index 0000000..69fe0c0
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/luci-statistics ) && rm -f /etc/uci-defaults/luci-statistics
+}
index 2288608..7fe96ca 100644 (file)
@@ -13,8 +13,8 @@ clean: luaclean
 
 luasource:
        mkdir -p dist$(LUCI_INSTALLDIR)
 
 luasource:
        mkdir -p dist$(LUCI_INSTALLDIR)
-       cp root/* dist -R 2>/dev/null || true
-       cp luasrc/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
+       cp -a root/* dist -R 2>/dev/null || true
+       cp -a luasrc/* dist$(LUCI_INSTALLDIR) -R 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 luacompile: luasource
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 luacompile: luasource
index b438760..7557c82 100644 (file)
@@ -62,7 +62,8 @@ endef
 
 
 define Package/luci/install/template
 
 
 define Package/luci/install/template
-       $(CP) $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+       $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
+       $(CP) -a $(PKG_BUILD_DIR)/$(2)/ipkg/* $(1)/CONTROL/ 2>/dev/null || true
 endef
 
 
 endef
 
 
@@ -163,7 +164,6 @@ endef
 
 define Package/luci-ff-halle/install
        $(call Package/luci/install/template,$(1),applications/community-halle)
 
 define Package/luci-ff-halle/install
        $(call Package/luci/install/template,$(1),applications/community-halle)
-       $(CP) -a ./ipkg/luci-ff-halle.postinst $(1)/CONTROL/postinst
 endef
 
 
 endef
 
 
@@ -181,7 +181,6 @@ endef
 
 define Package/luci-ff-leipzig/install
        $(call Package/luci/install/template,$(1),applications/community-leipzig)
 
 define Package/luci-ff-leipzig/install
        $(call Package/luci/install/template,$(1),applications/community-leipzig)
-       $(CP) -a ./ipkg/luci-ff-leipzig.postinst $(1)/CONTROL/postinst
 endef
 
 
 endef
 
 
@@ -199,7 +198,6 @@ endef
 
 define Package/luci-ff-hannover/install
        $(call Package/luci/install/template,$(1),applications/community-hannover)
 
 define Package/luci-ff-hannover/install
        $(call Package/luci/install/template,$(1),applications/community-hannover)
-       $(CP) -a ./ipkg/luci-ff-hannover.postinst $(1)/CONTROL/postinst
 endef
 
 
 endef
 
 
@@ -257,7 +255,6 @@ endef
 
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
 
 define Package/luci-app-firewall/install
        $(call Package/luci/install/template,$(1),applications/luci-fw)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-fw/dist/etc/init.d/luci_fw $(1)/etc/init.d
 endef
 
 
 endef
 
 
@@ -315,9 +312,6 @@ endef
 
 define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
 
 define Package/luci-app-statistics/install
        $(call Package/luci/install/template,$(1),applications/luci-statistics)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
-       $(CP) -a ./ipkg/luci-statistics.postinst $(1)/CONTROL/postinst
 endef
 
 
 endef
 
 
@@ -331,7 +325,6 @@ endef
 
 define Package/luci-sgi-haserl/install
        $(call Package/luci/install/template,$(1),libs/sgi-haserl)
 
 define Package/luci-sgi-haserl/install
        $(call Package/luci/install/template,$(1),libs/sgi-haserl)
-       $(CP) -a ./ipkg/luci-sgi-haserl.postinst $(1)/CONTROL/postinst
 endef
 
 
 endef
 
 
diff --git a/contrib/package/luci/ipkg/luci-ff-halle.postinst b/contrib/package/luci/ipkg/luci-ff-halle.postinst
deleted file mode 100755 (executable)
index 0efb5a9..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-community-halle ) && rm -f /etc/uci-defaults/luci-community-halle
-}
diff --git a/contrib/package/luci/ipkg/luci-ff-hannover.postinst b/contrib/package/luci/ipkg/luci-ff-hannover.postinst
deleted file mode 100755 (executable)
index b41179f..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-community-hannover ) &&      rm -f /etc/uci-defaults/luci-community-hannover
-}
diff --git a/contrib/package/luci/ipkg/luci-ff-leipzig.postinst b/contrib/package/luci/ipkg/luci-ff-leipzig.postinst
deleted file mode 100755 (executable)
index 5aff5db..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-community-leipzig ) &&       rm -f /etc/uci-defaults/luci-community-leipzig
-}
diff --git a/contrib/package/luci/ipkg/luci-sgi-haserl.postinst b/contrib/package/luci/ipkg/luci-sgi-haserl.postinst
deleted file mode 100755 (executable)
index 483a086..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-PATTERNS='/cgi-bin/luci/admin:root:$p$root /cgi-bin/luci-upload:root:$p$root'
-
-for i in $PATTERNS
-do
-       grep "$i" ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo "$i" >> ${IPKG_INSTROOT}/etc/httpd.conf
-done 
-
-[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart
diff --git a/contrib/package/luci/ipkg/luci-statistics.postint b/contrib/package/luci/ipkg/luci-statistics.postint
deleted file mode 100755 (executable)
index 69fe0c0..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
-       ( . /etc/uci-defaults/luci-statistics ) && rm -f /etc/uci-defaults/luci-statistics
-}
diff --git a/libs/sgi-haserl/ipkg/postinst b/libs/sgi-haserl/ipkg/postinst
new file mode 100755 (executable)
index 0000000..483a086
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+PATTERNS='/cgi-bin/luci/admin:root:$p$root /cgi-bin/luci-upload:root:$p$root'
+
+for i in $PATTERNS
+do
+       grep "$i" ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo "$i" >> ${IPKG_INSTROOT}/etc/httpd.conf
+done 
+
+[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart