contrib/package: switch default TLS provider to CyaSSL
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 23 Mar 2010 00:20:39 +0000 (00:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 23 Mar 2010 00:20:39 +0000 (00:20 +0000)
contrib/package/luci/Makefile

index 7cdcb7a..5cfab4c 100644 (file)
@@ -275,7 +275,7 @@ endef
 
 
 
 
 
 
-NIXIO_TLS:=axtls
+NIXIO_TLS:=cyassl
 
 define Package/luci-nixio
   $(call Package/luci/libtemplate)
 
 define Package/luci-nixio
   $(call Package/luci/libtemplate)
@@ -290,7 +290,7 @@ endef
 define Package/luci-nixio/config
        choice
                prompt "TLS Provider"
 define Package/luci-nixio/config
        choice
                prompt "TLS Provider"
-               default PACKAGE_luci-nixio_axtls
+               default PACKAGE_luci-nixio_cyassl
 
                config PACKAGE_luci-nixio_axtls
                        bool "Builtin (axTLS)"
 
                config PACKAGE_luci-nixio_axtls
                        bool "Builtin (axTLS)"
@@ -305,6 +305,10 @@ define Package/luci-nixio/config
        endchoice
 endef
 
        endchoice
 endef
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_axtls),)
+  NIXIO_TLS:=axtls
+endif
+
 ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
 ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif