fixed dynapoint.lua, there was no translation
authorVladimir <picfun@ya.ru>
Tue, 23 Jan 2018 18:48:28 +0000 (21:48 +0300)
committerStan Grishin <stangri@melmac.net>
Fri, 26 Jan 2018 03:51:03 +0000 (19:51 -0800)
Signed-off-by: Vladimir <picfun@ya.ru>
applications/luci-app-simple-adblock/Makefile
applications/luci-app-simple-adblock/luasrc/model/cbi/simpleadblock.lua

index d7be685..31055f1 100644 (file)
@@ -7,9 +7,10 @@ PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
 
 LUCI_TITLE:=Simple Adblock Web UI
-LUCI_DEPENDS:=+simple-adblock
+LUCI_DESCRIPTION:=Provides Web UI for simple-adblock service.
+LUCI_DEPENDS:=+luci +simple-adblock
 LUCI_PKGARCH:=all
-PKG_RELEASE:=2
+PKG_RELEASE:=5
 
 include ../../luci.mk
 
index ff4638e..e80cfb3 100644 (file)
@@ -11,10 +11,11 @@ end
 
 function e.write(self, section, value)
        if value == "1" then
-               luci.sys.call("/etc/init.d/simple-adblock enable >/dev/null")
-               luci.sys.call("/etc/init.d/simple-adblock start >/dev/null")
+               luci.sys.init.enable("simple-adblock")
+               luci.sys.init.start("simple-adblock")
        else
-               luci.sys.call("/etc/init.d/simple-adblock stop >/dev/null")
+               luci.sys.init.stop("simple-adblock")
+               luci.sys.init.disable("simple-adblock")
        end
        return Flag.write(self, section, value)
 end