* luci: fix stripping of certain multi line comments
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 29 Jun 2008 18:42:59 +0000 (18:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 29 Jun 2008 18:42:59 +0000 (18:42 +0000)
build/module.mk

index 032fc8d..8e403a0 100644 (file)
@@ -20,7 +20,7 @@ luasource:
        cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
        cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm $$i -rf; done
        cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
        cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm $$i -rf; done
-       for i in $$(find dist -type f -name '*.lua'); do perl -e 'undef $$/; open( F, "< $$ARGV[0]" ) || die $$!; $$src = <F>; close F; $$src =~ s/--\[\[.*?\]\]--//gs; $$src =~ s/^\s*--.*?\n//gm; open( F, "> $$ARGV[0]" ) || die $$!; print F $$src; close F' $$i; done
+       for i in $$(find dist -type f -name '*.lua'); do perl -e 'undef $$/; open( F, "< $$ARGV[0]" ) || die $$!; $$src = <F>; close F; $$src =~ s/--\[\[.*?\]\](--)?//gs; $$src =~ s/^\s*--.*?\n//gm; open( F, "> $$ARGV[0]" ) || die $$!; print F $$src; close F' $$i; done
 
 luacompile: luasource
        for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done
 
 luacompile: luasource
        for i in $$(find dist -name *.lua -not -name debug.lua); do $(LUAC) $(LUAC_OPTIONS) -o $$i $$i; done