build: add "po" target to Makefile
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 14 May 2009 21:10:40 +0000 (21:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 14 May 2009 21:10:40 +0000 (21:10 +0000)
Makefile
build/i18n-lua2po.pl

index a45d39e..4abb358 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -66,6 +66,12 @@ uvldocs: hostenv
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
        "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
 
        build/hostenv.sh $(realpath host) $(LUA_MODULEDIR) $(LUA_LIBRARYDIR) \
        "build/uvldoc $(realpath host) $(UVL_SCHEMEDIR) uvldocs $(DOCS)"
 
+po:
+       for L in $${LANGUAGE:-$$(find i18n/ -path 'i18n/*/luasrc/i18n/*' -name 'default.*.lua' | \
+         sed -e 's!.*/default\.\(.*\)\.lua!\1!')}; do \
+           build/i18n-lua2po.pl . $(realpath host)/po $$L; \
+       done
+
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #
 run:
        #       make run is deprecated                          #
        #       Please use:                                     #
index a9bc3b4..4905bb4 100755 (executable)
@@ -73,9 +73,9 @@ if( open F, "find . -path '*/luasrc/i18n/*' -name '*.$master_lang.lua' |" )
                                printf "Generating %-40s ",
                                        "$target_dir/$basename.$ext";
                
                                printf "Generating %-40s ",
                                        "$target_dir/$basename.$ext";
                
-                               printf T "#  %s.%s.po\n#  generated from %s\n\nmsgid \"\"\n" .
+                               printf T "#  %s.%s\n#  generated from %s\n\nmsgid \"\"\n" .
                                         "msgstr \"Content-Type: text/plain; charset=UTF-8\"\n\n",
                                         "msgstr \"Content-Type: text/plain; charset=UTF-8\"\n\n",
-                                       $basename, $target_lang, $file;
+                                       $basename, $ext, $file;
                
                                while( chomp( my $entry = readline L ) )
                                {
                
                                while( chomp( my $entry = readline L ) )
                                {