build: also prepare i18n directories
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 19 May 2009 02:50:52 +0000 (02:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 19 May 2009 02:50:52 +0000 (02:50 +0000)
build/config.mk
build/module.mk

index bac250d..31279ba 100644 (file)
@@ -7,10 +7,10 @@ LUA_LIBRARYDIR = /usr/lib/lua
 
 LUCI_MODULEDIR = $(LUA_MODULEDIR)/luci
 LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
 
 LUCI_MODULEDIR = $(LUA_MODULEDIR)/luci
 LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
+LUCI_I18NDIR = $(LUA_MODULEDIR)/luci/i18n
 
 UVL_SCHEMEDIR = host/lib/uci/schema
 
 HTDOCS = /www
 
 LUA=$(shell which lua)
 
 UVL_SCHEMEDIR = host/lib/uci/schema
 
 HTDOCS = /www
 
 LUA=$(shell which lua)
-XSLTPROC=$(shell which xsltproc)
index 70d54dc..ecc7a92 100644 (file)
@@ -25,8 +25,9 @@ luasource:
        cp -pR htdocs/* dist$(HTDOCS) 2>/dev/null || true
        for i in $$(find dist -name .svn -or -name .gitignore); do rm -rf $$i || true; done
   ifneq ($(PO),)
        cp -pR htdocs/* dist$(HTDOCS) 2>/dev/null || true
        for i in $$(find dist -name .svn -or -name .gitignore); do rm -rf $$i || true; done
   ifneq ($(PO),)
+       mkdir -p dist$(LUCI_I18NDIR)
        for file in $(PO); do \
        for file in $(PO); do \
-         cp $(HOST)/lua-po/$$file.$(if $(PO_LANG),$(PO_LANG),*).lua dist$(LUCI_MODULEDIR)/i18n/; \
+         cp $(HOST)/lua-po/$$file.$(if $(PO_LANG),$(PO_LANG),*).lua dist$(LUCI_I18NDIR)/ 2>/dev/null || true; \
        done
   endif
 
        done
   endif