luci-lib-luaneightbl: add src Makefile and fix dependencies (#282)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Jan 2015 12:04:01 +0000 (13:04 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 9 Jan 2015 12:04:01 +0000 (13:04 +0100)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
libs/luci-lib-luaneightbl/Makefile
libs/luci-lib-luaneightbl/src/Makefile [new file with mode: 0644]

index d9ab980..f0185b8 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=neightbl - Lua lib for IPv6 neighbors
-LUCI_DEPENDS:=+luci-base
+LUCI_DEPENDS:=+liblua
 
 include ../../luci.mk
 
diff --git a/libs/luci-lib-luaneightbl/src/Makefile b/libs/luci-lib-luaneightbl/src/Makefile
new file mode 100644 (file)
index 0000000..f856d2f
--- /dev/null
@@ -0,0 +1,17 @@
+NEIGHTBL_CFLAGS = -std=gnu99
+NEIGHTBL_LDFLAGS = -llua -lm
+NEIGHTBL_OBJ = neightbl.o
+NEIGHTBL_LIB = neightbl.so
+
+%.o: %.c
+       $(CC) $(CPPFLAGS) $(CFLAGS) $(LUA_CFLAGS) $(NEIGHTBL_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: $(NEIGHTBL_OBJ)
+       $(CC) $(LDFLAGS) -shared -o $(NEIGHTBL_LIB) $(NEIGHTBL_OBJ) $(NEIGHTBL_LDFLAGS)
+
+install: compile
+       mkdir -p $(DESTDIR)/usr/lib/lua
+       cp $(NEIGHTBL_LIB) $(DESTDIR)/usr/lib/lua/$(NEIGHTBL_LIB)
+
+clean:
+       rm -f *.o *.so