trunk: remove luci-app-initmgr, its part of admin-full now
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 4 May 2011 22:03:07 +0000 (22:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 4 May 2011 22:03:07 +0000 (22:03 +0000)
applications/luci-initmgr/Makefile [deleted file]
applications/luci-initmgr/luasrc/controller/init.lua [deleted file]
applications/luci-initmgr/luasrc/model/cbi/init/init.lua [deleted file]
applications/luci-initmgr/luasrc/model/cbi/init/startup.lua [deleted file]
contrib/package/luci/Makefile

diff --git a/applications/luci-initmgr/Makefile b/applications/luci-initmgr/Makefile
deleted file mode 100644 (file)
index 5e05cb7..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-PO = initmgr
-
-include ../../build/config.mk
-include ../../build/module.mk
diff --git a/applications/luci-initmgr/luasrc/controller/init.lua b/applications/luci-initmgr/luasrc/controller/init.lua
deleted file mode 100644 (file)
index f3fa7ef..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-module("luci.controller.init", package.seeall)
-
-function index()
-       if not nixio.fs.access("/etc/rc.common") then
-               return
-       end
-
-       require("luci.i18n")
-       luci.i18n.loadc("initmgr")
-
-       entry(
-               {"admin", "services", "init"}, form("init/init"),
-               luci.i18n.translate("Initscripts"), 0
-       ).i18n = "initmgr"
-
-       entry(
-               {"admin", "services", "init", "startup" },form("init/startup"),
-               luci.i18n.translate("Local Startup"), 10).i18n = "initmgr"
-end
diff --git a/applications/luci-initmgr/luasrc/model/cbi/init/init.lua b/applications/luci-initmgr/luasrc/model/cbi/init/init.lua
deleted file mode 100644 (file)
index d988b3a..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-
-$Id$
-]]--
-
-require("luci.sys")
-require("luci.util")
-
-local inits = { }
-
-for _, name in ipairs(luci.sys.init.names()) do
-       local index   = luci.sys.init.index(name)
-       local enabled = luci.sys.init.enabled(name)
-
-       inits["%02i.%s" % { index, name }] = {
-               name    = name,
-               index   = tostring(index),
-               enabled = enabled
-       }
-end
-
-
-m = SimpleForm("initmgr", translate("Initscripts"), translate("You can enable or disable installed init scripts here. Changes will applied after a device reboot.<br /><strong>Warning: If you disable essential init scripts like \"network\", your device might become inaccesable!</strong>"))
-m.reset = false
-m.submit = false
-
-
-s = m:section(Table, inits)
-
-i = s:option(DummyValue, "index", translate("Start priority"))
-n = s:option(DummyValue, "name", translate("Initscript"))
-
-
-e = s:option(Button, "endisable", translate("Enable/Disable"))
-
-e.render = function(self, section, scope)
-       if inits[section].enabled then
-               self.title = translate("Enabled")
-               self.inputstyle = "save"
-       else
-               self.title = translate("Disabled")
-               self.inputstyle = "reset"
-       end
-
-       Button.render(self, section, scope)
-end
-
-e.write = function(self, section)
-       if inits[section].enabled then
-               inits[section].enabled = false
-               return luci.sys.init.disable(inits[section].name)
-       else
-               inits[section].enabled = true
-               return luci.sys.init.enable(inits[section].name)
-       end
-end
-
-
-start = s:option(Button, "start", translate("Start"))
-start.inputstyle = "apply"
-start.write = function(self, section)
-       luci.sys.call("/etc/init.d/%s %s" %{ inits[section].name, self.option })
-end
-
-restart = s:option(Button, "restart", translate("Restart"))
-restart.inputstyle = "reload"
-restart.write = start.write
-
-stop = s:option(Button, "stop", translate("Stop"))
-stop.inputstyle = "remove"
-stop.write = start.write
-
-
-return m
diff --git a/applications/luci-initmgr/luasrc/model/cbi/init/startup.lua b/applications/luci-initmgr/luasrc/model/cbi/init/startup.lua
deleted file mode 100644 (file)
index f304706..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---[[
-LuCI - Lua Configuration Interface
-
-Copyright 2008 Steven Barth <steven@midlink.org>
-Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
-Copyright 2010 Manuel Munz <freifunk at somakoma dot de>
-
-Licensed under the Apache License, Version 2.0 (the "License");
-you may not use this file except in compliance with the License.
-You may obtain a copy of the License at
-
-       http://www.apache.org/licenses/LICENSE-2.0
-]]--
-
-local fs = require "nixio.fs"
-local rc = "/etc/rc.local" 
-
-f = SimpleForm("rc", translate("Local Startup"), translate("This is the content of /etc/rc.local. Insert your own commands here (in front of 'exit 0') to execute them at the end of the boot process."))
-
-t = f:field(TextValue, "rcs")
-t.rmempty = true
-t.rows = 20
-function t.cfgvalue()
-       return fs.readfile(rc) or ""
-end
-
-function f.handle(self, state, data)
-       if state == FORM_VALID then
-               if data.rcs then
-                       fs.writefile(rc, data.rcs:gsub("\r\n", "\n"))
-               end
-       end
-       return true
-end
-
-return f
index 8aea077..fcfe695 100644 (file)
@@ -378,9 +378,6 @@ $(eval $(call application,hd-idle,Hard Disk Idle Spin-Down module,\
 $(eval $(call application,tinyproxy,Tinyproxy - HTTP(S)-Proxy configuration,\
        +luci-mod-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
 
 $(eval $(call application,tinyproxy,Tinyproxy - HTTP(S)-Proxy configuration,\
        +luci-mod-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
 
-$(eval $(call application,initmgr,LuCI Initscript Management,\
-       +luci-mod-admin-full))
-
 $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
        +PACKAGE_luci-app-polipo:polipo))
 
 $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
        +PACKAGE_luci-app-polipo:polipo))
 
@@ -537,12 +534,12 @@ endef
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
        +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
 $(eval $(call collection,,\
        Standard OpenWrt set including full and mini admin and the standard theme,\
        +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-app-initmgr +libiwinfo))
+       +libiwinfo))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
        +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
        +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
-       +luci-app-firewall +luci-app-initmgr +libiwinfo))
+       +luci-app-firewall +libiwinfo))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\