build: add i18n-sync.sh, a script to automatically sync most translations
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 27 Jun 2012 18:02:50 +0000 (18:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 27 Jun 2012 18:02:50 +0000 (18:02 +0000)
build/i18n-sync.sh [new file with mode: 0755]

diff --git a/build/i18n-sync.sh b/build/i18n-sync.sh
new file mode 100755 (executable)
index 0000000..137852b
--- /dev/null
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+for m in */*/Makefile; do
+       if grep -qE '^PO *=' $m; then
+               p="${m%/Makefile}"
+               t="$(sed -ne 's/^PO *= *//p' $m)"
+
+               case "$t" in
+                       *\ *)
+                               echo "WARNING: Cannot handle $p" >&2
+                               continue
+                       ;;
+                       *base*)
+                               continue
+                       ;;
+               esac
+
+               if [ -f "po/templates/$t.pot" ]; then
+                       ./build/i18n-scan.pl "$p" > "po/templates/$t.pot"
+               fi
+       fi
+done
+
+./build/i18n-update.pl po