contrib/uhttpd: add patch to fix linking on recent distros, refresh environment patch
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Dec 2012 16:38:41 +0000 (16:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 28 Dec 2012 16:38:41 +0000 (16:38 +0000)
contrib/uhttpd/patches/001-pass-env.patch
contrib/uhttpd/patches/002-link-order.patch [new file with mode: 0644]
contrib/uhttpd/patches/series

index b69ff17..ab607db 100644 (file)
@@ -1,7 +1,7 @@
 --- a/uhttpd-cgi.c
 +++ b/uhttpd-cgi.c
 --- a/uhttpd-cgi.c
 +++ b/uhttpd-cgi.c
-@@ -204,7 +204,7 @@ void uh_cgi_request(struct client *cl, s
-                           (pi->stat.st_mode & S_IXOTH)
+@@ -216,7 +216,7 @@ void uh_cgi_request(
+                            (pi->stat.st_mode & S_IXOTH)) || (ip != NULL)
                        ) {
                                /* build environment */
 -                              clearenv();
                        ) {
                                /* build environment */
 -                              clearenv();
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
new file mode 100644 (file)
index 0000000..8bdd335
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ endif
+       $(CC) $(CFLAGS) -c -o $@ $<
+ compile: $(OBJ) $(TLSLIB) $(LUALIB)
+-      $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
++      $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
+ clean:
+       rm -f *.o *.so uhttpd
index dc852df..8a1834e 100644 (file)
@@ -1 +1,2 @@
 001-pass-env.patch
 001-pass-env.patch
+002-link-order.patch