contrib/package: properly escape postinstall of freifunk-firewall
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 16 Jun 2009 23:12:33 +0000 (23:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 16 Jun 2009 23:12:33 +0000 (23:12 +0000)
contrib/package/freifunk-firewall/Makefile

index 24be151..8399870 100644 (file)
@@ -37,7 +37,7 @@ endef
 
 define Package/freifunk-firewall/postinst
 #!/bin/sh
-[ -n "${IPKG_INSTROOT}" ] || {
+[ -n "$${IPKG_INSTROOT}" ] || {
   if ! grep -q /etc/firewall.freifunk /etc/config/firewall; then
     uci add firewall include >/dev/null
     uci set firewall.@include[-1].path=/etc/firewall.freifunk