applications/luci-udpxy: add new package. 237/head
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 28 Oct 2014 17:03:18 +0000 (18:03 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 28 Oct 2014 17:03:18 +0000 (18:03 +0100)
This adds support for configuring udpxy.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
applications/luci-udpxy/Makefile [new file with mode: 0644]
applications/luci-udpxy/luasrc/controller/udpxy.lua [new file with mode: 0644]
applications/luci-udpxy/luasrc/model/cbi/udpxy.lua [new file with mode: 0644]
applications/luci-udpxy/root/etc/uci-defaults/luci-udpxy [new file with mode: 0644]
contrib/package/luci-addons/Makefile

diff --git a/applications/luci-udpxy/Makefile b/applications/luci-udpxy/Makefile
new file mode 100644 (file)
index 0000000..05228b1
--- /dev/null
@@ -0,0 +1,4 @@
+PO = udpxy
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-udpxy/luasrc/controller/udpxy.lua b/applications/luci-udpxy/luasrc/controller/udpxy.lua
new file mode 100644 (file)
index 0000000..bc85b0b
--- /dev/null
@@ -0,0 +1,25 @@
+--[[
+LuCI - Lua Configuration Interface - udpxy support
+
+Copyright 2014 Álvaro Fernández Rojas <noltari@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.udpxy", package.seeall)
+
+function index()
+       if not nixio.fs.access("/etc/config/udpxy") then
+               return
+       end
+
+       local page = entry({"admin", "services", "udpxy"}, cbi("udpxy"), _("udpxy"))
+       page.dependent = true
+
+end
diff --git a/applications/luci-udpxy/luasrc/model/cbi/udpxy.lua b/applications/luci-udpxy/luasrc/model/cbi/udpxy.lua
new file mode 100644 (file)
index 0000000..fb3080a
--- /dev/null
@@ -0,0 +1,73 @@
+--[[
+LuCI - Lua Configuration Interface - udpxy support
+
+Copyright 2014 Álvaro Fernández Rojas <noltari@gmail.com>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+m = Map("udpxy", "udpxy", translate("udpxy is a UDP-to-HTTP multicast traffic relay daemon, here you can configure the settings."))
+
+s = m:section(TypedSection, "udpxy", "")
+s.addremove = true
+s.anonymous = false
+
+enable=s:option(Flag, "disabled", translate("Enabled"))
+enable.enabled="0"
+enable.disabled="1"
+enable.default = "1"
+respawn=s:option(Flag, "respawn", translate("Respawn"))
+respawn.default = false
+
+verbose=s:option(Flag, "verbose", translate("Verbose"))
+verbose.default = false
+
+status=s:option(Flag, "status", translate("Status"))
+
+bind=s:option(Value, "bind", translate("Bind IP/Interface"))
+bind.rmempty = true
+bind.datatype = "or(ipaddr, network)"
+
+port=s:option(Value, "port", translate("Port"))
+port.rmempty = true
+port.datatype = "port"
+
+source=s:option(Value, "source", translate("Source IP/Interface"))
+source.rmempty = true
+source.datatype = "or(ipaddr, network)"
+
+max_clients=s:option(Value, "max_clients", translate("Max clients"))
+max_clients.rmempty = true
+max_clients.datatype = "range(1, 5000)"
+
+log_file=s:option(Value, "log_file", translate("Log file"))
+log_file.rmempty = true
+--log_file.datatype = "file"
+
+buffer_size=s:option(Value, "buffer_size", translate("Buffer size"))
+buffer_size.rmempty = true
+buffer_size.datatype = "range(4096,2097152)"
+
+buffer_messages=s:option(Value, "buffer_messages", translate("Buffer messages"))
+buffer_messages.rmempty = true
+buffer_messages.datatype = "or(-1, and(min(1), uinteger))"
+
+buffer_time=s:option(Value, "buffer_time", translate("Buffer time"))
+buffer_time.rmempty = true
+buffer_time.datatype = "or(-1, and(min(1), uinteger))"
+
+nice_increment=s:option(Value, "nice_increment", translate("Nice increment"))
+nice_increment.rmempty = true
+nice_increment.datatype = "or(and(max(-1), integer),and(min(1), integer))"
+
+mcsub_renew=s:option(Value, "mcsub_renew", translate("Multicast subscription renew"))
+mcsub_renew.rmempty = true
+mcsub_renew.datatype = "or(0, range(30, 64000))"
+
+return m
diff --git a/applications/luci-udpxy/root/etc/uci-defaults/luci-udpxy b/applications/luci-udpxy/root/etc/uci-defaults/luci-udpxy
new file mode 100644 (file)
index 0000000..e93c078
--- /dev/null
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+# needed for "Save and Apply" to restart udpxy
+uci -q batch <<-EOF >/dev/null
+       delete ucitrack.@udpxy[-1]
+       add ucitrack udpxy
+       set ucitrack.@udpxy[-1].init="udpxy"
+       commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0
index ac31b63..9742d0c 100644 (file)
@@ -171,6 +171,7 @@ $(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
 $(eval $(call application,voice-core,LuCI Voice Software (Core)))
 $(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),luci-app-diag-devinfo))
 
 $(eval $(call application,voice-core,LuCI Voice Software (Core)))
 $(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),luci-app-diag-devinfo))
 
+$(eval $(call application,udpxy,LuCI Support for udpxy,udpxy))
 $(eval $(call application,upnp,Universal Plug & Play configuration module,miniupnpd))
 $(eval $(call application,ntpc,NTP time synchronisation configuration module,ntpclient))
 $(eval $(call application,ddns,Dynamic DNS configuration module,ddns-scripts))
 $(eval $(call application,upnp,Universal Plug & Play configuration module,miniupnpd))
 $(eval $(call application,ntpc,NTP time synchronisation configuration module,ntpclient))
 $(eval $(call application,ddns,Dynamic DNS configuration module,ddns-scripts))