Merge pull request #1311 from dibdot/dnscrypt-proxy
authorHannu Nyman <hannu.nyman@iki.fi>
Fri, 18 Aug 2017 07:08:43 +0000 (10:08 +0300)
committerGitHub <noreply@github.com>
Fri, 18 Aug 2017 07:08:43 +0000 (10:08 +0300)
luci-app-dnscrypt-proxy: fix ssl dependency

applications/luci-app-dnscrypt-proxy/Makefile
applications/luci-app-dnscrypt-proxy/luasrc/model/cbi/dnscrypt-proxy/overview_tab.lua

index ec4a1d9..4b632b8 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 LUCI_TITLE:=LuCI support for DNSCrypt-Proxy
-LUCI_DEPENDS:=+libustream-mbedtls +dnscrypt-proxy
+LUCI_DEPENDS:=+uclient-fetch +dnscrypt-proxy
 LUCI_PKGARCH:=all
 
 include ../../luci.mk
index ea61366..de23ba0 100644 (file)
@@ -11,6 +11,13 @@ local plug_cnt  = tonumber(luci.sys.exec("env -i /usr/sbin/dnscrypt-proxy --vers
 local res_list  = {}
 local url       = "https://download.dnscrypt.org/dnscrypt-proxy/dnscrypt-resolvers.csv"
 
+if not fs.access("/lib/libustream-ssl.so") then
+       m = SimpleForm("error", nil, translate("SSL support not available, please install an libustream-ssl variant to use this package."))
+       m.submit = false
+       m.reset = false
+       return m
+end
+
 if not fs.access(res_input) then
        luci.sys.call("env -i /bin/uclient-fetch --no-check-certificate -O " .. res_input .. " " .. url .. " >/dev/null 2>&1")
 end