contrib/package: target name was stripped from base-files package name upstream,...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Aug 2009 17:56:48 +0000 (17:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 22 Aug 2009 17:56:48 +0000 (17:56 +0000)
contrib/package/remote-update/Makefile
contrib/package/remote-update/files/usr/sbin/remote-update

index 40cee4c..dd73d2f 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=remote-update
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index bffc449..e9a0a98 100755 (executable)
@@ -8,8 +8,11 @@ local NL='
 
 find_architecture()
 {
-       opkg list_installed 'base-files-*' | \
-               sed -ne 's/base-files-\([^ ]\+\).*/\1/p'
+       local ifs="$IFS"; IFS="-"
+       set -- $(opkg list_installed kernel)
+       IFS="$ifs"
+
+       echo "$3"
 }
 
 find_image()